[Video][Camera] Blank Screen After You Quickly Switch Between Camera/Video Taking

RESOLVED DUPLICATE of bug 809259

Status

RESOLVED DUPLICATE of bug 809259
6 years ago
6 years ago

People

(Reporter: wachen, Assigned: mikeh)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
*Environment:
Phone - Otoro
Gaia - 16fda982b02d7279abd1c15b66af25e692d502f3
Gecko - e070197f4c89

*How to reproduce:
1. Unlock the phone
2. Go to camera
3. Click the video button on the bottom-right
4. Click the camera button on the bottom-right
5. repeat the Step 3~4 quickly for 1~2 times

*Expected Result:
   The screen should show what the camera pointing at.

*Actual Result:
  Blank screen.

Updated

6 years ago
blocking-basecamp: --- → ?

Comment 1

6 years ago
sounds like a memory issue
(Reporter)

Comment 2

6 years ago
*Note: 
  1. This is 11/04 PST Gecko Aurora Build
  2. Not the whole going blank, the button is still there. However, the preview before taking picture/video became black screen

Comment 3

6 years ago
Walter,
Are you able to easily recover from the 'blank screen'?  Or must you kill camera, and start again?
Duplicate of this bug: 809259
(Reporter)

Comment 5

6 years ago
Hi, 
    I am unable to recover it from the blank screen with 3 button. 3 buttons would be there. You can switch to gallery, but if you switch back the camera won't recover from its original status. Also, if you trigger the button to take the shot, the button would grey out. And, switching between camera or video doesn't work any more.
    You must kill camera and start again.

Comment 6

6 years ago
mike, can you take a look at what might be going on?
Assignee: nobody → mhabicher
blocking-basecamp: ? → +
(In reply to Doug Turner (:dougt) from comment #6)
>
> mike, can you take a look at what might be going on?

I've been digging through this since last week; looks like under some conditions, the camera driver exhausts its shared memory and doesn't recover.  Investigation is continuing.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 809259
(Reporter)

Comment 9

6 years ago
umm...It's strange to mark backward since this one opened earlier.
And, this one is one for otoro.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

6 years ago
Depends on: 809259
(In reply to Walter Chen from comment #9)
> umm...It's strange to mark backward since this one opened earlier.
> And, this one is one for otoro.

I marked this one a dupe because the other bug has more detailed information, and I strongly suspect these are related.  I'm happy to leave them separated too.
(Reporter)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 809259
You need to log in before you can comment on or make changes to this bug.