Chrome debugging broke B2G debugging

RESOLVED FIXED in Firefox 19

Status

()

Firefox
Developer Tools: Debugger
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: past, Assigned: past)

Tracking

Trunk
Firefox 19
All
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g])

Attachments

(1 attachment)

Bug 740551 apparently broke debugging on B2G. I now get the following error while connecting:

E/GeckoConsole(   77): [JavaScript Error: "aHooks.browser.contentWindow is undefined" {file: "chrome://global/content/devtools/dbg-script-actors.js" line: 35}]
(Assignee)

Updated

5 years ago
Whiteboard: [b2g]
(Assignee)

Comment 1

5 years ago
Created attachment 678261 [details] [diff] [review]
Bustage fix

Apparently it wasn't a good idea to move the content window extraction code into the thread actor. The browser actors is a better place, since it can be nicely overridden by other products.
Attachment #678261 - Flags: review?(vporof)
Attachment #678261 - Flags: review?(21)
Comment on attachment 678261 [details] [diff] [review]
Bustage fix

Review of attachment 678261 [details] [diff] [review]:
-----------------------------------------------------------------

Fresh as it used to be. LGTM.
Attachment #678261 - Flags: review?(vporof) → review+
Attachment #678261 - Flags: review?(21) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/774f55987329
Whiteboard: [b2g] → [b2g][fixed-in-fx-team]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 809226
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/774f55987329
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [b2g][fixed-in-fx-team] → [b2g]
Target Milestone: --- → Firefox 19
You need to log in before you can comment on or make changes to this bug.