crash in mozilla::MediaPipelineTransmit::PipelineListener::NotifyQueuedTrackChanges

RESOLVED DUPLICATE of bug 807238

Status

()

Core
WebRTC: Signaling
P2
critical
RESOLVED DUPLICATE of bug 807238
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash})

Trunk
crash
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC][blocking-webrtc+], crash signature)

(Reporter)

Description

6 years ago
There are a few crashes in the trunk.

Signature 	mozilla::MediaPipelineTransmit::PipelineListener::NotifyQueuedTrackChanges(mozilla::MediaStreamGraph*, int, int, __int64, unsigned int, mozilla::MediaSegment const&) More Reports Search
UUID	c35cd4b6-ac3c-4875-9e54-1647f2121105
Date Processed	2012-11-05 11:38:34
Uptime	8780
Last Crash	2.4 hours before submission
Install Age	2.9 hours since version was first installed.
Install Time	2012-11-05 08:46:42
Product	Firefox
Version	19.0a1
Build ID	20121104030714
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 42 stepping 7
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x0102, AdapterSubsysID: 04ad1028, AdapterDriverVersion: 8.15.10.2418
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
EMCheckCompatibility	True
Adapter Vendor ID	0x8086
Adapter Device ID	0x0102
Total Virtual Memory	4294836224
Available Virtual Memory	3235454976
System Memory Use Percentage	40
Available Page File	13011914752
Available Physical Memory	5008932864

Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::MediaPipelineTransmit::PipelineListener::NotifyQueuedTrackChanges 	media/webrtc/signaling/src/mediapipeline/MediaPipeline.cpp:567
1 	xul.dll 	mozilla::MediaStreamGraphImpl::ExtractPendingInput 	content/media/MediaStreamGraph.cpp:612
2 	xul.dll 	mozilla::MediaStreamGraphImpl::RunThread 	content/media/MediaStreamGraph.cpp:1391
3 	xul.dll 	mozilla::`anonymous namespace'::MediaStreamGraphThreadRunnable::Run 	content/media/MediaStreamGraph.cpp:1523
4 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
5 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:265
6 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:395
7 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:90
8 	msvcr100.dll 	_callthreadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:314
9 	msvcr100.dll 	_threadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:292
10 	kernel32.dll 	BaseThreadInitThunk 	
11 	ntdll.dll 	__RtlUserThreadStart 	
12 	ntdll.dll 	_RtlUserThreadStart

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3AMediaPipelineTransmit%3A%3APipelineListener%3A%3ANotifyQueuedTrackChanges%28mozilla%3A%3AMediaStreamGraph*%2C+int%2C+int%2C+__int64%2C+unsigned+int%2C+mozilla%3A%3AMediaSegment+const%26%29
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3AMediaPipelineTransmit%3A%3APipelineListener%3A%3ANotifyQueuedTrackChanges%28mozilla%3A%3AMediaStreamGraph*%2C+int%2C+int%2C+long+long%2C+unsigned+int%2C+mozilla%3A%3AMediaSegment+const%26%29
Not clear as to how this happens or the exact source; could be due to some of the to-be-landed locking code, so deferring for the time being
Priority: -- → P2
Needs a reproducible test case via HTML before making it crashtest worthy.
Flags: in-testsuite-

Updated

6 years ago
Whiteboard: [WebRTC][blocking-webrtc+]
pipeline_ was probably nulled by ::Detach() before the listener was removed; duping
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 807238
You need to log in before you can comment on or make changes to this bug.