Closed Bug 808540 Opened 7 years ago Closed 6 years ago

“Switch to tab” can go between Panorama tab groups, but Ctrl+Tab cannot (difficult to return)

Categories

(Firefox :: Tabbed Browser, defect)

17 Branch
x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30

People

(Reporter: Aleksej, Assigned: D-Kalck)

References

Details

(Keywords: regression, ue, ux-error-recovery, Whiteboard: [bugday-20140219])

Attachments

(1 file, 2 obsolete files)

0. Set browser.ctrlTab.previews to “true”.  That is not necessary, but helps to see what is going on.
1. Open two tab groups, with at least two tabs in the 1st one.  Remember how to get autocomplete for one of the tabs in the first group.
2. Go to the 2nd tab group.
3. Enter location bar search for a tab in the 1st tab group.
-> a “Switch to tab” entry appears.
4. Do “switch to tab”.
-> You are on a tab in the 1st tab group.
5. Press (optionally hold) Ctrl+Tab.


Actual results:
* You can go to a tab in the 1st tab group only.
* There is no indication of which tab group you came from.

Expected results:
* You can go to the tab in the 2nd tab group where you’ve entered you search.  That’s what happens when “Switch to tab” sends you to a tab in the same tab group.
Nightly 20121105030642 19.0a1
Beta 17.0b4
Keywords: ue
Could you explain a bit more what you mean by "You can go to the tab in the 2nd tab group where you’ve entered you search." (your expected result)?

Do you mean you want Firefox to either:
1. Pull/copy the tab from the first tab group into the second.
2. Disallow "Switch to tab" when the tab is on a different tab group, so the URL will open in the current tab.
3. Explicitly indicate "Switch to tab in other tab group", so that you know that you are leaving the current tab group.
(In reply to d from comment #3)

I mean having the MRU-ordered list span across tab groups, so that it shows the tabs I have actually seen last, penultimate etc, even if they are in a different tab group.

Of your guesses,
#1 is confusing (either it is a tab symlink which I don’t know is implemented, or it is a fake Switch to Tab, or the 1st tab group will lose the tab);
#2 is good (at least if you are not used to “Switch to tab”);
#3 is a workaround, but not very helpful, because still it requires the user to know that easy returning is not possible.
Summary: “Switch to tab” can go between Panorama tab groups, but Ctrl+Tab cannot → “Switch to tab” can go between Panorama tab groups, but Ctrl+Tab cannot (difficult to return)
Hello, I did the patch to make the Ctrl-Tab behavior with hidden tabs (tabs from other tab groups) consistent.

You can switch tab groups by pressing Ctrl-` (back-tick), but it might not be what you want - it cycles through all tab groups. Perhaps we can make it cycle between recently-used tab groups.

If "browser.ctrlTab.previews" is off, the behavior of cycling from left-to-right only in the current tab group is consistent with the "Ctrl-Tab previews" behavior. I think "browser.ctrlTab.previews" is turned off by default, so other users will also face the same problem in that they cannot quickly return to their initial tab group. But I've heard that Tab Mix Plus turns this preference on. Correct me if I'm wrong on any point here.

So in my opinion, maybe we can have a way to copy and open the tab's URL in the current tab group as an alternative for all "Switch to tab" options, and for these cases, display "Switch to tab in other tab group", so that the user can choose whether to do that or to reopen the URL in the current tab group. For me, I sometimes find the "Switch to tab" option annoying =).
Keywords: regression
Now I am using the ability to switch to a tab in a different tab group often, so I wouldn’t like it turned off.  I am still being confused by this bug.  If not yet an ability to go back, could it have the target group name in the hint (only if the group is different)?
Version: Trunk → 17 Branch
For me, I use tab groups merely as a way to organize tabs so that the tab bar would not be crowded with 100+ tabs. I still need the ability to use Ctrl+Tab to switch to tabs just used even in other tab groups. Can we find a way to allow the old behaviour?
Or at least, yes, make Ctrl+` to switch to the tab group just used (with a list of all groups available), not to cycle through all of them, because we may have 5+ groups in use, and cycling-through is very impracticalbe.

I don't know if built-in Ctrl+Tab has been changed to the way window managers do with Alt+Tab, and I always have to install the "Ctrl-Tab" addon to have the proper behaviour. Such behaviour should be the default way IMHO, and also be applied to Ctrl+` too.

But still, for me the best way is the old way of Ctrl+Tab to switch to any other tabs, no matter which group they belong to. When Firefox changes its behaviour, can there be an option to keep the old way?
Please revert bug 724346
Any update about this one ? Ctrl+Tab is useless since bug 724346.
If someone wants to write a patch, I'd be happy to review it.
Attached patch revert bug 724346 (obsolete) — Splinter Review
This patch should revert bug 724346.
This is my first patch, I hope this is not too bad.
Attachment #8374111 - Flags: review?(dao)
Attachment #8374111 - Flags: review?(dao) → review+
Assignee: nobody → d-kalck
Keywords: checkin-needed
Attached patch revert bug 724346 v2 (obsolete) — Splinter Review
Better diff style (added -p -g -U 8 to hg diff).
Attachment #8374111 - Attachment is obsolete: true
Attachment #8374128 - Flags: review?(dao)
Attachment #8374128 - Flags: review?(dao) → review+
Granted review+ since I only changed diff style. Hope it's not a problem.
Status: NEW → ASSIGNED
Looks like Hg doesn't like this patch :(. Please make sure it follows the guidelines from the link below (including proper commit information).
https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F

Thanks!
Keywords: checkin-needed
Second attempt to provide a proper patch.
Attachment #8374128 - Attachment is obsolete: true
Attachment #8374304 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/36ed2f492316
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
As someone who actually uses different tab groups for different activities, this change is horrible. When I change to another tab group, I now have to use other, slower methods of tab switching until my MRU list is occupied with useful stuff again.

Robert mentioned as a reason for this change: "I use tab groups merely as a way to organize tabs so that the tab bar would not be crowded with 100+ tabs". Just wondering: what's the use of the tab bar not being crowded? In each case, you probably have about 10 tabs visible in the tab bar, and you'll need search features (such as "Switch to tab", which you mention) to change between other tabs than the ones that aren't visible. So how does it even matter if they're in a different tab group or not, if the tabs aren't related to each other anyway? (note: this is a genuine question, not some sort of "you're doing it wrong!". I try to understand the reason of this change, because I personally don't see it. Other people haven't explained their use cases at all.)

I for one know very well in what tab group I am at any given moment, because they have a meaning for me. If I switch to another tab group, I know where I came from and I won't return until I want to continue whatever I was doing. In that case I can use the search feature to find the tab, or in an extreme case where I don't remember the exact website/page title, first change to the right tab group and then ctrl-tab to get back to where I was. This change completely obliterates any chances to get back to my previous state, as I could before.

A better solution to this problem would probably be to, as proposed, indicate a tab proposed by "Switch to tab" is in another group, so even if you don't know what group you are in at a given moment, you can at least first have a look before changing.

As a sidenote: "Switch to tab" also works between different windows, not only different tab groups. Extending the logic in this bug, would mean that ctrl-tab should also work between different windows. I think it is clear that this is unmanageable.
Verified fixed with 2014-02-18-03-02-02-mozilla-central-firefox-30.0a1.ru.linux-x86_64.
Status: RESOLVED → VERIFIED
Whiteboard: [bugday-20140219]
(In reply to Timvde from comment #19)
> A better solution to this problem would probably be to, as proposed,
> indicate a tab proposed by "Switch to tab" is in another group, so even if

bug 594995
See Also: → 594995
Hello Timvde,

I understand your concerns. Actually I am also using tab groups for different activities, and I like this feature a lot. I may not be precise enough when I said "merely as a way to organize..." It's just that Firefox is lacking a convenient way to switch between different tab groups: the Ctrl+` shortcut only switches in a cycle order, but what if I use more tab groups? How many times I must press the combination to cycle back to the group I was just in? I hoped that Ctrl+` can behave in the way like Ctrl+Tab switching tabs back-and-forth or like Alt+Tab switching windows, to easily switch to recently used items, but it's still missing in Firefox. And as for the Panorama view, it even lacks a shortcut to invoke that beautiful view! (correct me if I am outdated with this)

I categorize my tabs into different groups too, but I often need to switch quickly back to a certain tab group, and the original way of Ctrl+Tab before this bug occurred suited my need, so that's why I was joining on the side to change it back or at least add an option switch to satisfy both group of users.

And allow me explain why my tab bar is crowded when tabs get numerous: I use Tab Mix Plus to adjust the tab width automatically so that even if there are 20~30 tabs they are still all fit in the screen and I can still access them easily without the need to scroll the tab bar left or right. This reduces the time to find the tab I want to switch to.

I agree that the Awesome Bar is a great tool to search for open tabs, however it requires a key combination Ctrl+L to activate the bar, with further typing of a couple of characters of the URL or title, so I prefer a visual way with maybe a single mouse click.

The best solution I suppose is to have an option in the Preferences dialog or an "about:config" attribute to control the way the user wants the Ctrl+Tab to switch across tab groups or just limited within the group. I do hope that changes introduced in Firefox do not always change in a new way and sacrifice the current preference and usage of users, or the discussion and controversy never end and only one side will be satisfied. That does not sound perfect.
Thanks for your reply. It seems like time flies, I thought I had only let this rest for a day or two before answering, but it's been a week! Sorry for the delay, I was kinda busy :)

It is true that Firefox lacks a decent way to switch between tab groups, but this feature is not the right way to do that.

- You'll quickly fill the 6 most recent tabs, making ctrl-tab unable to switch to another tab group at all

- You'll only be able to switch to the most recently used tab group (maybe two, if you're lucky). It is by no means a good way to switch tab groups in general. I use Panorama for that, and luckily: yes, it has always had an (albeit not very known) shortcut: ctrl-shift-e. And maybe this add-on might suit your needs too: https://addons.mozilla.org/nl/firefox/addon/tab-group-bar/

I see what the problem of too many tabs in one group is for you now. I always disliked that (Chromesk) behaviour, exactly for that reason :) For me, having a decent tab title and scroll a little helps more to find the right tab than having a lot of icons with maybe a letter or two, but I guess that's just a matter of taste/habit.

I actually *don't* like the awesome bar to switch tabs :) I also use an add-on for that (since the removal of browser.allTabs.previews, an awesome feature). A little off-topic, but just to be complete (and who knows, you might like it :) ): https://addons.mozilla.org/en-US/firefox/addon/all-tabs-helper/

It also broke the "Show x tabs" button in some way. It shows the total number of tabs in all tab groups together, while actually activating it shows the "All tab" overflow panel, which, of course, only lists tabs of the current group. It is in my opinion inconvenient that they don't agree. Changing the number to the current tab group would be weird too, because "all" tabs would not include other tabs that are visible.

But in the end I agree an about:config option would be perfect, if the new behaviour is really what some users prefer. It'd be weird to have it in the preferences dialog though, as browser.ctrlTab.previews isn't even in there entirely (which is a shame, because it's really a killer feature of Firefox!). I hope the developers consider adding the pref :)
In bug 724346 I did attach a patch that will revert the behaviour by default (which now is reverted permanently) but allow turning it on with a preference. I don't remember if I tested it though.
So, this bug is dead now? No chance of adding a pref for this, admittedly, rather arbitrary choice?
The arbitrary choice was bug #724346 not this one.
The choice is arbitrary in any case, it doesn't really matter which one was first. This landed almost a year ago now, and I still can't get used to this behaviour. I keep switching tab groups by accident (with a lot of administration overhead afterwards to move everything where it should).

So if possible, I'd still like a pref to switch this back to make ctrl-tab work per-tab group. It just feels unintuitive (for me) in its current implementation.
Hi, although my preference is exactly the opposite with Timvde, but I too support to add a pref for switching this and that.

The proposed pref by lwz and Darren was rejected by Dao in #724346, because he "was not convinced to add a pref". It's a shame. I still agree with Timvde, because if I'm in his shoes, I too may hope to have a pref to switch to tabs only within the tab group, since the tab group function was indeed meant to organize tabs into different scenarios and topics.

If we propose the pref "browser.ctrlTab.showHiddenTabs" to be added again, in which bug should we do this? How do you agree with this idea?
It may be controversial to fix a bug and then revert the change because of lack of / late participation in the forum. It may also be hard because there are too many bugs out there and people tend to find one day when Firefox upgrades that some function has been changed, and will only search for / raise the relevant bug when that happens.

But I still hope that preference switches can be added along with any behavioral changes of Firefox, because you won't know if changing some behavior affects the habitude of usage of some group of people else. Let's hope there not be arbitrary choices as possible, can we?
In short, I do not hope the end of this story is permanently "we win back the behavior we like, while making people like Timvde who do have a need to switch only within tab groups feel inconvenient". Hope this will have a win-win solution.
You need to log in before you can comment on or make changes to this bug.