[gcli] "addon list" output is malformed

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
4 months ago

People

(Reporter: unghost, Assigned: miker)

Tracking

unspecified
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 678285 [details]
Screenshot of bug

STR:
1) Open console
2) Enter "addon list"

Expected result:
Nicely formatted list of addons

Actual result:
See screnshot

Comment 1

6 years ago
(s/console/gcli)
Component: Developer Tools: Console → Developer Tools
Summary: "addon list" output is malformed → [gcli] "addon list" output is malformed
<![CDATA[add-on blah enabled]]>
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Duplicate of this bug: 813181

Comment 4

6 years ago
Created attachment 687943 [details] [diff] [review]
fix patch 1

 * use context.createView() on "addon list"
 * rid "addon enable/disable" of CDATA section

Comment 5

6 years ago
I created patch (comment #4)
Could you review it.
Attachment #687943 - Flags: review?(jwalker)
Comment on attachment 687943 [details] [diff] [review]
fix patch 1

Review of attachment 687943 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch.
r+ from me, but I'd like Mike to take a quick look as the author of this command.
Attachment #687943 - Flags: review?(jwalker) → review?(mratcliffe)
Comment on attachment 687943 [details] [diff] [review]
fix patch 1

Looks great, r+ from me
Attachment #687943 - Flags: review?(mratcliffe) → review+
Whiteboard: [land-in-fx-team]
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/ef3ec5487993
Flags: in-testsuite-
Keywords: checkin-needed
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.