Closed Bug 808906 Opened 12 years ago Closed 12 years ago

[socorro-crashstats] certain query/signature in report/list throws a 500

Categories

(Socorro :: Webapp, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: stephend, Assigned: rhelmer)

References

()

Details

Traceback (most recent call last):

  File "/data/socorro-crashstats/vendor/lib/python/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/socorro-crashstats/crashstats/crashstats/views.py", line 155, in inner
    return view(request, *args, **kwargs)

  File "/data/socorro-crashstats/crashstats/crashstats/views.py", line 1049, in report_list
    return render(request, 'crashstats/report_list.html', data)

  File "/data/socorro-crashstats/vendor/lib/python/django/shortcuts/__init__.py", line 44, in render
    return HttpResponse(loader.render_to_string(*args, **kwargs),

  File "/data/socorro-crashstats/vendor/lib/python/django/template/loader.py", line 176, in render_to_string
    return t.render(context_instance)

  File "/data/socorro-crashstats/vendor/src/jingo/jingo/__init__.py", line 189, in render
    return super(Template, self).render(context_dict)

  File "/data/socorro-crashstats/vendor-local/lib/python/jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)

  File "/data/socorro-crashstats/crashstats/crashstats/templates/crashstats/report_list.html", line 1, in top-level template code
    {% extends "crashstats/report_list_base.html" %}

  File "/data/socorro-crashstats/crashstats/crashstats/templates/crashstats/report_list_base.html", line 1, in top-level template code
    {% extends "crashstats_base.html" %}

  File "/data/socorro-crashstats/crashstats/base/templates/crashstats_base.html", line 171, in top-level template code
    {% block site_js %}

  File "/data/socorro-crashstats/crashstats/crashstats/templates/crashstats/report_list.html", line 350, in block "site_js"
    path: '/{{ product }}/{{ version }}/{{ correlation_os | urlencode }}/{{ signature|urlencode }}/',

  File "/data/socorro-crashstats/crashstats/crashstats/helpers.py", line 26, in urlencode
    return urllib.quote_plus(txt)

  File "/usr/lib64/python2.6/urllib.py", line 1241, in quote_plus
    if ' ' in s:

TypeError: argument of type 'NoneType' is not iterable
Looks like this was caused by 807133, correlation_os can be None (not sure why that'd ever be the case yet, though)
Assignee: nobody → rhelmer
Status: NEW → ASSIGNED
Oh well in this example, the OS is 100% unknown. OK then!
Commits pushed to master at https://github.com/mozilla/socorro-crashstats

https://github.com/mozilla/socorro-crashstats/commit/97d73271053f38c314c3065551a9397d440c0adf
bug 808906 - there may be no correlation_os, if this is the empty signature for example

https://github.com/mozilla/socorro-crashstats/commit/660eea57564233a5abb6e893d600190b371d729b
Merge pull request #271 from rhelmer/bug808906-guard-correlation_os

fixes bug 808906 - there may be no correlation_os, if this is the empty signat...
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.