Text fields do not accept 8bit characters

VERIFIED DUPLICATE of bug 74088

Status

()

--
major
VERIFIED DUPLICATE of bug 74088
18 years ago
18 years ago

People

(Reporter: olaf, Assigned: masaki.katakai)

Tracking

({intl})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Linux CVS build from 20010513.
I can't enter ISO8859-1 8bit characters into text entry fields. They get
displayed as a funny inverted "?" symbol and submitted as a literal "?". This
means when I type e.g. the proper German name of Cologne or Munich into a form
entry it gets submitted as "M?nchen", which may render it impossible for the
server to process the request correctly.
Keywords: intl

Comment 1

18 years ago
doesn't sound like a sizing issue - reassigning
Assignee: rods → beppe

Comment 2

18 years ago
an URL for the problem?
(Reporter)

Comment 3

18 years ago
URL? any one with a text entry field, just try www.yahoo.de (since that's in
german it definitely needs to accept iso8859-1)

Comment 4

18 years ago
Running 2001051308 / Win98SE, I tried 
http://www.google.de and
http://www.yahoo.de

All three accepted 'ä','ü','ö','ß' etc.
Furthermore, running this build, I just typed these "Umlaute" in Bugzilla's textbox.

Comment 5

18 years ago
assigning to ftang for initial investigation -- Frank, this looks like it may be
a wfm, but I wanted you to look at it first.
Assignee: beppe → ftang

Comment 6

18 years ago
Linux-only issue?
Maybe some fonts are missing or something like that?
no problem on Win2K

Comment 7

18 years ago
can you make a screen shot and attach to the bug report ?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 8

18 years ago
Created attachment 34701 [details]
google start page with text entry

Comment 9

18 years ago
does it always show this <?> for latin text?
This looks like an rendering issue, not an input issue.
Maski- can you help to take a look at this ?
From the screenshot, It seems a ISO10646 font get used and claim it have such 
glyph but it only have the replacement glyph. 
are you using TTF ?

Comment 10

18 years ago
reassign to katakai
Assignee: ftang → katakai
Status: ASSIGNED → NEW
(Reporter)

Comment 11

18 years ago
It is not _just_ a rendering issue. The chars are submitted as an ASCII question
mark. Pressing the search button I find %3F in the URL at the place of any umlaut.
I do use TT fonts but the exact same config works fine in Mozilla 0.9, has
anything changed since wrt. font selection?

Even if it is a font problem, this should not affect form submission and we have
a slightly different bug.
(Assignee)

Comment 12

18 years ago
I've checked this on nightly on Solaris, yes, actually I can not
enter into the text field in the web page. I want to ask you to
verify the following, Sorry for stupid question, I know how to
input german on only Solaris. Can you tell me the exact instruction
on Linux with Japanese keyboards???

- Is this problem new on 0513 build? How about Mozilla 0.9, 0.8, 0.7?
- What will happen when you copy&past german text to the field
- What will happen when you type in URL field. (not on the input field,
  try URL field of Mozilla, also text field on Find dialog)
  In my environment of Solaris, I could enter in URL field and
  text field of Find. This problem happens on text field of web page,
  compose window.

Thanks.
Status: NEW → ASSIGNED
(Reporter)

Comment 13

18 years ago
I see this problem the first time. It is definitely not in 0.9 or dailies from
the weeks preceding it.

When I type an a-umlaut in the URL field, it gets displayed as the inverted
question mark symbol and submitted as %EF%BF%BD. That is UTF-8 for #FFFD, the
Unicode "replacement character", which is apparently also the character which
produces that strange glyph.

Copy and paste works in form field. Copy and paste in URL field displays
correctly and submits in UTF-8.
Typing in Find dialog produces the replacement character, paste in Find dialog
works.
(Assignee)

Comment 14

18 years ago
I found the exact problem and I've attached the patch in bug 74088.
If you have time, can you try the patch and put the results into bug 74088?

marked as DUP.


*** This bug has been marked as a duplicate of 74088 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 15

18 years ago
Sorry, I can't do any further testing by now, lack of time :-(

Comment 16

18 years ago
verifying duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.