"ASSERTION: must have binding parent when in native anonymous subtree with a parent node: '!IsInNativeAnonymousSubtree() || GetBindingParent() || !GetParent()', file nsIContent.h, line 230" when handling load/error event for generated image content

RESOLVED FIXED

Status

()

Core
DOM: Events
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: smaug, Assigned: smaug)

Tracking

(Depends on: 1 bug, {assertion})

Trunk
x86
Windows XP
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

+++ This bug was initially created as a clone of Bug #791201 +++

load and error events are dispatched async, so generated content may not be in 
document anymore.
Created attachment 678690 [details]
testcase
Created attachment 678697 [details] [diff] [review]
patch

I think we should tweak the assertion a bit.

I'll file a new bug to not fire load and error for generated image.
Attachment #678697 - Flags: review?(bzbarsky)
https://tbpl.mozilla.org/?tree=Try&rev=265f8f2f9b35
Created attachment 678714 [details] [diff] [review]
patch

Ooops, this is the patch.
Attachment #678697 - Attachment is obsolete: true
Attachment #678697 - Flags: review?(bzbarsky)
Attachment #678714 - Flags: review?(bzbarsky)
Comment on attachment 678714 [details] [diff] [review]
patch

r=me
Attachment #678714 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/79b844b41d08
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Olli, the regular startup assertion failure is gone.  Thanks!

Comment 8

5 years ago
Thanks for fixing and reviewing this, smaug and bz. :)
Depends on: 735135
No longer depends on: 735135
Duplicate of this bug: 735135
You need to log in before you can comment on or make changes to this bug.