Restarting the app after a different theme was enabled will still display the previous one

VERIFIED FIXED in Firefox 19

Status

()

Firefox for Android
Theme and Visual Design
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: xti, Assigned: sriram)

Tracking

19 Branch
Firefox 20
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox19 verified, firefox20 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Firefox 19.0a1 (2012-11-06)
Device: Galaxy S2
OS: Android 4.0.3

Steps to reproduce:
1. Go to http://www.getpersonas.com/en-US/ and add a couple of themes
2. Go to about:addons (Menu > Tools > Add-ons)
3. Tap on a grayed out theme and enable it
4. Restart app

Expected result:
The enabled theme at step 3 is displayed.

Actual result:
The same theme that is was active before step 3, is still displayed after restart.

Updated

6 years ago
Depends on: 783092

Updated

6 years ago
Assignee: nobody → sriram
(Assignee)

Comment 1

6 years ago
Created attachment 683262 [details] [diff] [review]
Patch

(Did I just fix a bug in Gecko side? :O )

This fixes the addons problem.
Attachment #683262 - Flags: review?(mark.finkle)
Comment on attachment 683262 [details] [diff] [review]
Patch

This looks right to me
Attachment #683262 - Flags: review?(mark.finkle) → review+
(Assignee)

Updated

6 years ago
No longer depends on: 809027
(Assignee)

Updated

6 years ago
Depends on: 809027

Comment 4

6 years ago
https://hg.mozilla.org/mozilla-central/rev/4436e4f53e55
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Sriram - I assume we want this uplifted to aurora?
status-firefox19: --- → affected
(Assignee)

Comment 6

6 years ago
Comment on attachment 683262 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Very old copy-paste bug between xul and native.
User impact if declined: Personas will be different when user re-opens Fennec.
Testing completed (on m-c, etc.): Landed on 11/29.
Risk to taking this patch (and alternatives if risky): Very low.
String or UUID changes made by this patch: -
Attachment #683262 - Flags: approval-mozilla-aurora?

Comment 7

6 years ago
Comment on attachment 683262 [details] [diff] [review]
Patch

In support of our new theming.
Attachment #683262 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/832f71d67907
status-firefox19: affected → fixed
status-firefox20: --- → fixed

Comment 9

6 years ago
Verified on:
Firefox 20.0a1 (2012-12-07)
Firefox 19.0a2 (2012-12-07)
Device: Galaxy S2
OS: Android 4.0.3
Status: RESOLVED → VERIFIED
status-firefox19: fixed → verified
status-firefox20: fixed → verified
Blocks: 783092
No longer depends on: 783092
(Assignee)

Updated

6 years ago
Duplicate of this bug: 809027
You need to log in before you can comment on or make changes to this bug.