Status

RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: hub, Assigned: fzzzy)

Tracking

Trunk
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [apps watch list1])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 678848 [details]
screenshot

When I start maps, they are not drawn properly. See attached screenshot. Unagi is the platform. Code from this morning.
This looks like your network connectivity dropped out.
(Reporter)

Comment 2

6 years ago
I am over cell data.
(Reporter)

Comment 3

6 years ago
If you look closely at the screenshot, the tiles will match if you remove the empty space. So it is not missing data.
(Reporter)

Comment 4

6 years ago
When I enabled wifi, it worked. But without I get the issue described above. What I suspect is that the Cell Data provider do some not nice things to the image behind the back, on insert http headers that cause Nokia own service to no return the right data.

Given that this a web app run from Nokia webservers, it might not be fixable by us. But it is rather bad that it does not work.


(note: this prevent me from dogfooding the maps)
(Reporter)

Comment 5

6 years ago
Now, here is the problem: I tried with the same carrier, with the mandatory proxy settings in the APN, with Android (CM9) and Firefox Nightly. And I get the exact same issue. Also when I load the market place, some icons look funny. What I suspect is that the proxy rewrite images in a way that mess the map up.

Updated

6 years ago
Whiteboard: [3rd-party-preloaded-apps]

Updated

6 years ago
Blocks: 815411

Updated

6 years ago
No longer blocks: 815411

Updated

6 years ago
Blocks: 815411

Updated

6 years ago
Whiteboard: [3rd-party-preloaded-apps]

Updated

6 years ago
Blocks: 837298
No longer blocks: 815411

Comment 6

6 years ago
Which proxy settings and provider are you guys using? 
Does this also affect other apps? (Marketplace is mentioned in Comment #5)
What can we do about this on Nokia side?
(Reporter)

Comment 7

6 years ago
(In reply to AndyT from comment #6)
> Which proxy settings and provider are you guys using? 
> Does this also affect other apps? (Marketplace is mentioned in Comment #5)
> What can we do about this on Nokia side?

Look for the APN "SpeakOut" (MVNO on Rogers).

Marketplace uses HTTPS so it is not affected. If we used HTTPS for the maps, I'm sure the problem would be solved.
(Reporter)

Comment 8

6 years ago
In the latest version of gaia / b2g, I can't even start the maps application.

But in the browser I get the maps, and they work better. But the resolution of the map tiles is awefull. Probably because of that rewriting the images.

Comment 9

6 years ago
This is a provider-specific problem. The only solution I can think of is to ask the operators involved (e.g. Telefonica) to whitelist our images from being crunched. The domain they should put on the whitelist are 
*.here.com
*.here.net
*.nlp.nokia.com
(Reporter)

Comment 10

6 years ago
This is not on Telefonica. This is in Canada on SpeakOut (7-Eleven) a MVNO on top of Rogers. Because that's currently the only solution to use the unagi phones in Canada.

Updated

6 years ago
Component: Gaia → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk

Comment 11

6 years ago
Is it still reproducible? Could you recheck it?
(Reporter)

Comment 12

6 years ago
I need to find the SIM card for that service and try again.

Updated

6 years ago
Whiteboard: [apps watch list]

Updated

6 years ago
Whiteboard: [apps watch list] → [apps watch list1]

Comment 13

6 years ago
Hubert - Can this be re-produced?
Flags: needinfo?(hub)
(Reporter)

Comment 14

6 years ago
I can't reproduce because of the following:

1. I no longer have said service (lost the SIM card, probably out of credit anyway and the "internet" service add-on is no longer available)
2. I am blocked by bug 861871 that prevents me from even using the HERE app.

So I can't confirm whether the bug still exist or has been fixed.

Now there is one way you can ensure it always works: use https everywhere.
Flags: needinfo?(hub)

Updated

6 years ago
Assignee: nobody → dpreston

Comment 15

6 years ago
Hello,

Switching from http to https means a higher latency for getting every tile. That's why we should double check if this switch does really make sense. Do you have any estimation how many other providers have a similar issue? Can you somehow check it for the countries/providers you're going to release FXOS devices in/with?

In a meanwhile we're trying to figure out if we have https support for tiles on our side.

Leo

Comment 16

5 years ago
Cannot be reproduced. Closing. Please re-open if steps to reproduce are available.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.