Closed Bug 809277 Opened 9 years ago Closed 9 years ago

OMTC Linux: crash at startup (back trace + glxinfo)

Categories

(Core :: Graphics: Layers, defect)

x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 806428

People

(Reporter: paul, Unassigned)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

Attached file glxinfo output
Attached, glxinfo output.

Graphics section from about:support:

  Graphics

        Adapter Description
        Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile

        Device ID
        Mesa DRI Intel(R) Ivybridge Mobile

        Driver Version
        3.0 Mesa 9.0

        GPU Accelerated Windows
        1/1 OpenGL

        Vendor ID
        Intel Open Source Technology Center

        WebGL Renderer
        Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile

        AzureCanvasBackend
        cairo

        AzureContentBackend
        none

        AzureFallbackCanvasBackend
        none


gdb trace:

#0  0x00007ffff7bc8d44 in pthread_mutex_lock () from /usr/lib/libpthread.so.0
#1  0x00007ffff438f837 in MessageLoop::PostTask_Helper(tracked_objects::Location const&, Task*, int, bool) () from /home/paul/.mozilla/firefox/libxul.so
#2  0x00007ffff37475e0 in mozilla::ipc::AsyncChannel::OnMessageReceivedFromLink(IPC::Message const&) () from /home/paul/.mozilla/firefox/libxul.so
#3  0x00007ffff3746850 in mozilla::ipc::AsyncChannel::ThreadLink::SendMessage(IPC::Message*) () from /home/paul/.mozilla/firefox/libxul.so
#4  0x00007ffff37470f3 in mozilla::ipc::AsyncChannel::Send(IPC::Message*) () from /home/paul/.mozilla/firefox/libxul.so
#5  0x00007ffff374a0f5 in mozilla::ipc::RPCChannel::Send(IPC::Message*) () from /home/paul/.mozilla/firefox/libxul.so
#6  0x00007ffff37c0333 in mozilla::layers::PLayerChild::Send__delete__(mozilla::layers::PLayerChild*) () from /home/paul/.mozilla/firefox/libxul.so
#7  0x00007ffff43c6792 in mozilla::layers::BasicShadowableLayer::~BasicShadowableLayer() () from /home/paul/.mozilla/firefox/libxul.so
#8  0x00007ffff43cbf6e in mozilla::layers::BasicShadowableContainerLayer::~BasicShadowableContainerLayer() () from /home/paul/.mozilla/firefox/libxul.so
#9  0x00007ffff43cbfb1 in mozilla::layers::BasicShadowableContainerLayer::~BasicShadowableContainerLayer() () from /home/paul/.mozilla/firefox/libxul.so
#10 0x00007ffff43c8056 in mozilla::layers::BasicLayerManager::~BasicLayerManager() () from /home/paul/.mozilla/firefox/libxul.so
#11 0x00007ffff43c8c91 in mozilla::layers::BasicShadowLayerManager::~BasicShadowLayerManager() () from /home/paul/.mozilla/firefox/libxul.so
#12 0x00007ffff3dad017 in mozilla::layers::LayerManager::Release() () from /home/paul/.mozilla/firefox/libxul.so
#13 0x00007ffff388a6ab in mozilla::layers::CompositorChild::~CompositorChild() () from /home/paul/.mozilla/firefox/libxul.so
#14 0x00007ffff388a6cb in mozilla::layers::CompositorChild::~CompositorChild() () from /home/paul/.mozilla/firefox/libxul.so
#15 0x00007ffff42ba7f3 in mozilla::layers::CompositorChild::Release() () from /home/paul/.mozilla/firefox/libxul.so
#16 0x00007ffff36be4b3 in nsBaseWidget::CreateCompositor() () from /home/paul/.mozilla/firefox/libxul.so
#17 0x00007ffff42bb536 in nsBaseWidget::GetLayerManager(mozilla::layers::PLayersChild*, mozilla::layers::LayersBackend, nsIWidget::LayerManagerPersistence, bool*) () from /home/paul/.mozilla/firefox/libxul.so
#18 0x00007ffff3e03bf8 in PresShell::Paint(nsIView*, nsRegion const&, unsigned int) () from /home/paul/.mozilla/firefox/libxul.so
#19 0x00007ffff40455bb in nsViewManager::ProcessPendingUpdatesForView(nsView*, bool) () from /home/paul/.mozilla/firefox/libxul.so
#20 0x00007ffff3e0510e in nsRefreshDriver::Notify(nsITimer*) () from /home/paul/.mozilla/firefox/libxul.so
#21 0x00007ffff436ebdf in nsTimerImpl::Fire() () from /home/paul/.mozilla/firefox/libxul.so
#22 0x00007ffff436ec85 in nsTimerEvent::Run() () from /home/paul/.mozilla/firefox/libxul.so
#23 0x00007ffff436b702 in nsThread::ProcessNextEvent(bool, bool*) () from /home/paul/.mozilla/firefox/libxul.so
#24 0x00007ffff43445cc in NS_ProcessNextEvent_P(nsIThread*, bool) () from /home/paul/.mozilla/firefox/libxul.so
#25 0x00007ffff42f167b in mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) () from /home/paul/.mozilla/firefox/libxul.so
#26 0x00007ffff438dfc3 in MessageLoop::Run() () from /home/paul/.mozilla/firefox/libxul.so
#27 0x00007ffff36bd3a4 in nsBaseAppShell::Run() () from /home/paul/.mozilla/firefox/libxul.so
#28 0x00007ffff35efd00 in nsAppStartup::Run() () from /home/paul/.mozilla/firefox/libxul.so
#29 0x00007ffff3cd605a in XREMain::XRE_mainRun() () from /home/paul/.mozilla/firefox/libxul.so
#30 0x00007ffff316c726 in XREMain::XRE_main(int, char**, nsXREAppData const*) () from /home/paul/.mozilla/firefox/libxul.so
#31 0x00007ffff316c8b5 in XRE_main () from /home/paul/.mozilla/firefox/libxul.so
#32 0x0000000000407227 in main ()
Severity: normal → critical
Crash Signature: [@ MessageLoop::PostTask_Helper]
Keywords: crash
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 806428
Paul, this stack probably means  that the crash occurred on another thread. If you can reproduce, please get the stack for the thread that actually crashed. You can switch threads in GDB with

  > thread N

you can list threads with

  > info threads

and you can print stacks for all threads by

  > thread apply all backtrace

Scoobidiver, for that reason that signature is not going to be specific to this thread, but I don't know if I should remove it: should signatures be the signature on the crashed thread or the signature on the main thread regardless of which thread crashed?
Didn't see that bug was already RESOLVED.
You need to log in before you can comment on or make changes to this bug.