Closed Bug 809363 Opened 9 years ago Closed 9 years ago

pref "gfx.textures.poweroftwo.force-enabled" accessed off the main thread

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 797120

People

(Reporter: nical, Assigned: nical)

References

Details

Attachments

(1 obsolete file)

GLContext::CanUploadNonPowerOfTwo is called on the compositor thread and accesses the pref "gfx.textures.poweroftwo.force-enabled".

The pref should be only accessed from the main thread.

http://dxr.mozilla.org/mozilla-central/gfx/gl/GLContext.cpp.html?string=GLContext.cpp#l639
Blocks: 619487, 722012
Assignee: nobody → nical.bugzilla
Attachment #679133 - Flags: review?(jmuizelaar)
By the way this fixes a systematic crash (abort) when shutting down debug builds of Firefox with omtc on Linux.
Actually jgilbert just landed a fix for this in bug 797120.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797120
Attachment #679133 - Flags: review?(jmuizelaar)
Attachment #679133 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.