Closed Bug 809493 Opened 8 years ago Closed 8 years ago

Div contents leak out when scrolling nested div on some frames

Categories

(Core :: Graphics: Layers, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: BenWa, Assigned: BenWa)

Details

(Whiteboard: [leave open])

Attachments

(1 file, 1 obsolete file)

STR:
1) Open layout/reftests/scrolling/opacity-mixed-scrolling-2.html on mobile
2) Pan the div slowly, sometimes the frame will stop with the contents leaking outside the bounds.
Most likely related: On this page I also see the that the opacity varies as you pan the page and scroll the div.
Note that these failures aren't caused by progressive painting but the artifacts are different with tiling.
(In reply to Benoit Girard (:BenWa) from comment #1)
> Most likely related: On this page I also see the that the opacity varies as
> you pan the page and scroll the div.

This looks like a state change. I can reproduce this reliably using:

0) Enable tile borders (optional).
1) Scroll the div (the div will get it's own layers and tile border).
2) Scroll the page such that the background comes into view.
3) If the div layer is still active and the background is into view the opacity will change.
Attached patch Part 1: Fix opacity (obsolete) — Splinter Review
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #679371 - Flags: review?(joe)
OS: Mac OS X → Android
Hardware: x86 → ARM
Attached patch patchSplinter Review
Correct blend equation this time.
Attachment #679371 - Attachment is obsolete: true
Attachment #679371 - Flags: review?(joe)
Attachment #679379 - Flags: review?(joe)
Attachment #679379 - Flags: review?(joe) → review+
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.