Closed Bug 809756 Opened 8 years ago Closed 8 years ago

Linux PGO builds timing out

Categories

(Core :: General, defect)

x86
Linux
defect
Not set
blocker

Tracking

()

RESOLVED FIXED

People

(Reporter: philor, Unassigned)

Details

https://tbpl.mozilla.org/php/getParsedLog.php?id=16833333&tree=Mozilla-Inbound

MOZ_PGO_INSTRUMENTED=1 OBJDIR=obj-firefox JARLOG_DIR=obj-firefox/jarlog/en-US python obj-firefox/_profile/pgo/profileserver.py 10
args: ['/builds/slave/m-in-lnx-pgo/build/obj-firefox/dist/firefox/firefox-bin', '-no-remote', '-profile', '/builds/slave/m-in-lnx-pgo/build/obj-firefox/_profile/pgo/pgoprofile/', 'http://localhost:8888/index.html']
INFO | automation.py | Application pid: 23164
Xlib:  extension "RANDR" missing on display ":2.0".
(that seems like An Clue to blame, but it is not, it's present in every run, green or not)
command timed out: 10800 seconds without output, attempting to kill

inbound regression range: https://tbpl.mozilla.org/php/getParsedLog.php?id=16833333&tree=Mozilla-Inbound

central regression range (since it merged that range): https://hg.mozilla.org/mozilla-central/rev/c652c39732f8

inbound and central are closed.
First failure on inbound was on the 9am periodic, the noon periodic on central was green, which should let infra changes off the hook.
A screenshot would have been useful.
Looks like this one is the culprit.
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=eb636c95b1c0

I think it's bug 803669, but it's safer to just backout everything.
(In reply to Mike Hommey [:glandium] from comment #5)
> Looks like this one is the culprit.
> https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=eb636c95b1c0
> 
> I think it's bug 803669, but it's safer to just backout everything.

Whilst the job hasn't yet completed, the PGO run on that push is definitely broken (both from runtime & stdio of that job) - and the push before was green, so I'm confident the backout will work. As such (and seeing as mozilla-central is already closed, so not much to lose), I'm going to merge to m-c before the tip retrigger (eta 1 hour) comes back.
That backout worked, trees reopened.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.