Plugin content can't be activated on sohu.com because it is covered by an <a> element

RESOLVED WONTFIX

Status

()

Core
Plug-ins
P2
major
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: Ioana (away), Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20121108])

(Reporter)

Description

5 years ago
Firefox 17 beta 5 (20121106195758) Flash 11.2, 11.5

STR:
1. Activate click to play and restart Firefox.
2. Load http://www.sohu.com/ in the browser (also reproducible on qq.com and sina.com.cn).
3. Click on all the gray areas with "Click here to activate the Adobe Flash plugin" on them.

Actual Results:
The plugin content gets loaded on the first few containers at the beginning of the page. When clicking on those from the bottom of the page, a link is opened in a new tab.
(Reporter)

Comment 1

5 years ago
Issue also reproducible on the 11/7 Nightly, and on Firefox 14 - where CTP landed.
Version: 17 Branch → Trunk
Blocks: 738698
(Reporter)

Comment 2

5 years ago
A similar issue is reproducible on the AVG site:

1. Enable CTP in your browser.
2. Go to http://www.avg.com/eu-en/tutorials.pnuid-1314787329808693a388fe8b6467daa1dadd9946b672a.
3. Click on one of the "How to" links. Click on the "Play video tutorial" link.
4. Activate the plugin content.

Actual Results:
Sometimes the user can activate the plugin content when performing these steps for the first time on a profile (didn't work on all new profiles). Most of the times, the plugin content is not activated.

Comment 3

5 years ago
This is not one bug. The sohu.com bug is an "issue" where the sohu.com website has Flash advertisements "covered" by an absolutely-positioned link element so that the click loads the ad instead of launching Flash. I do think we should fix this case (probably by disabling the CTP UI for that element and using out-of-page UI), but it's not urgent.

The issue in comment 2 is entirely separate, deserves another bug, and I cannot reproduce it.

Updated

5 years ago
Summary: Plugin content can't be activated on some top 100 sites → Plugin content can't be activated on sohu.com because it is covered by an <a> element
(Reporter)

Comment 4

5 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #3)
> The issue in comment 2 is entirely separate, deserves another bug, and I
> cannot reproduce it.

I logged bug 809860 for comment 2 since I can reproduce it on all platforms, on Firefox 14.0.1, 17b5, and 11/07 Nightly.

I will try to make a video of the issue reproducing (where it is obvious I am making the click that should activate the plugin) and upload it on the new report.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #3)
> I do think we should fix this case (probably by disabling the CTP UI for that
> element and using out-of-page UI), but it's not urgent.

Given that I assume we should not track for Firefox 17 but possibly track for Firefox 18, 19, or later?
Whiteboard: [testday-20121108]

Comment 6

5 years ago
No, I don't think tracking flags are worthwhile for this bug.
Priority: -- → P2
Let's consolidate those overlay issues (see bug 752516 comment 3 and 4).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752516
Reopened based on https://bugzilla.mozilla.org/show_bug.cgi?id=853973#c28
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 10

4 years ago
Not sure why we're reopening. The infobar appears, and as far as I can tell everything is now behaving as we intend.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → WONTFIX
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #3)
> The sohu.com bug is an "issue" where the sohu.com
> website has Flash advertisements "covered" by an absolutely-positioned link
> element so that the click loads the ad instead of launching Flash. I do
> think we should fix this case (probably by disabling the CTP UI for that
> element and using out-of-page UI), but it's not urgent.
This is still reproducible.

Comment 12

4 years ago
Yes, and we "fixed" it by disabling the ctp UI and using the out-of-page UI...
Try with the blocked ads from the bottom of the page, not with the top ones. No infobar/pop-up appears, just a new tab opens.

Comment 14

4 years ago
What do you mean "try with"?

There are Flash plugins large enough to see on the page, so we don't show the infobar. The plugins covered by a link don't show the "Click to activate" text, and follow the link. This is all as intended.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #14)
> What do you mean "try with"?
Click on

> There are Flash plugins large enough to see on the page, so we don't show
> the infobar. The plugins covered by a link don't show the "Click to
> activate" text, and follow the link. This is all as intended.
It's just a discoverability thing. To unblock those ads, you have 2 options now: from the doorhanger or by clicking on an other (not covered by links) blocked content.

Comment 16

4 years ago
ok, then this is WONTFIX
ok, thanks
You need to log in before you can comment on or make changes to this bug.