ESPN serves Firefox for Android a basic HTML mobile site instead of touch version

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: xti, Assigned: karlcow)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [clientsniff][contactready] [country-us], URL)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 679601 [details]
Firefox for Android - Beta 17

Firefox 17.0b5 (2012-11-07)
Device: Galaxy S2
OS: Android 4.0.3

Steps to reproduce:
1. Go to espn.go.com

Expected result:
ESPN touch version is loaded.

Actual result:
A basic HTML mobile site is loaded (see attached screenshot).

Notes:
On stock browser, the correct site version is loaded.
The page looks different on the Nightly and Aurora than it looks on the stock browser and it looks on the Beta build.
(Reporter)

Comment 1

6 years ago
Created attachment 679602 [details]
Stock browser
(Reporter)

Comment 2

6 years ago
Created attachment 679629 [details]
Firefox for Android - Nightly 19, Aurora 18
(Reporter)

Updated

6 years ago
Blocks: 747123

Updated

6 years ago
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Firefox 17 → unspecified
Interesting. I see the touch site using Firefox 16. Using Nightly 19 I see the desktop site. Seems to be a regression. Perhaps they don't recognize the updated version in the UA.

As the screenshots show, ESPN is also not serving their videos to Firefox. (Main picture is a click target in the stock browser but not in Firefox.)
still an issue, also confirming differences betwen Fx versions..
See Also: → bug 828431
Seems much of the sniffing and adaptation is in JS. It's clearly meant to be progressively enhanced and degrade gracefully, and I must say that the version Firefox on Android gets by default also is pretty good. However, it would be nice to also get the videos and such..
Whiteboard: [clientsniff][contactready]
(Assignee)

Updated

5 years ago
Whiteboard: [clientsniff][contactready] → [clientsniff][contactready] [country-us]
I am able to play videos on FF Android now, though Chrome is still providing the enhanced UI.
(Assignee)

Comment 7

5 years ago
adam,

can you play the video at m.espn.go.com/mens-college-basketball/story/_/id/10263556/louisville-chris-jones-trying-measure-memphis-joe-jackson
No, 404
(Assignee)

Comment 9

5 years ago
Yes my bad. Being too quick. The link is 
http://m.espn.go.com/ncb/story?storyId=10263556&src=desktop&wjb

Sorry about that.
(Assignee)

Comment 11

5 years ago
Trying to contact a person on ESPN team
https://github.com/orgs/espn/members

Hopefully he can redirect me to the right person. That would be pretty cool.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
https://twitter.com/davidpean/status/430762212018233344
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.