view source is tied to URL value, not actual page contents

VERIFIED DUPLICATE of bug 55583

Status

VERIFIED DUPLICATE of bug 55583
18 years ago
14 years ago

People

(Reporter: old-mozilla, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I'm not sure what component should own this, so I'll welcome whatever routing
folks deem appropriate. I've also set OS/platform to all based on seeing this on
windows, linux and aix... the assumption being that this is a xp problem.

If you have a web page that is generated from a form post that doesn't change
the URL from one form to the next, then the view source functionality is totally
broken as it never picks up newer pages. In the case of the "weblication" (I
hate that name, but that's what they want to call it) I'm developing large
portions of the system are driven by php scripts using POST forms where the
values that are posted on subsequent calls manipulate the forms that are
presented. For example, when you first open foo.php as a normal get (no
variables passed in) you are presented an opening menu which contains a form
with type POST and url $PHP_SELF, an additional field of type string named
"what" represents which option you choose, and then posts back a sub menu which
has the same form with the same "what" field and an additional field "how" that
is filled in on that form... this continues through several steps, adding more
and more data along the path until the final confirmation where you may have
upwards of 30 pieces of information collected and finally commit the desired
action; afterward you are returned to a previous menu, either the "what" menu or
the "how" menu depending on a number of issues. You can easily go hundreds or
thousands of requests without the url ever changing, my record according to
server logs is over 10K durring a week of testing (never bothered to close
mozilla for about a week, just xlocked).

Now in all of that time moz is clearly fetching a nuber of different pages, and
they do not all have the same source, but no matter when durring that sequence
you choose view source you always get the same source... the initial page that
was fetched, the "what" menu. This can be absolutely infuriating when you're
trying to debug why a specific page several steps deep into the menu renders
oddly under mozilla. (it was an inproperly nested tag, we found it with konquerer.)

If someone needs to see an example of this I can create one if you have a php
enabled server.
This is a known issue.

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
yuo
(Reporter)

Comment 3

18 years ago
ARGH! "view-source" not "view source" nor "viewsource" nor "source view"... no
wonder I couldn't find it in my queries... thanks guys!

Comment 4

18 years ago
Verified Dupe...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.