Dialogs can't be refocused after losing focus by ReflectionX

NEW
Unassigned

Status

()

18 years ago
16 years ago

People

(Reporter: wr0ngway, Unassigned)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9) Gecko/20010505
BuildID:    2001050515

Under Windows, I use ReflectionX as my X server, as well as managing my
window/mouse focus. I have it set to Focus follows mouse, and raise windows on
focus.  As a result, if any mozilla dialogs are opened, and my mouse happens to
not be over it (or I move it by accident), the focus ends up shifting away from
that dialog, and I CANNOT get back focus of the dialog to dismiss it.

Reproducible: Always
Steps to Reproduce:
1. Setup a windows utility to cause focus to follow mouse and raise windows on focus
2. Open any dialog, e.g Edit -> Preferences
3. Cause focus to shift away from that dialog


Actual Results:  Could not refocus on dialog
Could not dismiss dialog.
Could not perform any actions in main window (though it seemed to have focus)
Had to kill mozilla

Expected Results:  Prevent focus from shifting away from dialog, or allow dialog
to regain focus or be dismissable

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 76814 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
This doesn't look like the same bug to me...  When bug 76814 is fixed, let's try
this one again.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
dialogs and focus, danm
Assignee: trudelle → danm

Comment 4

17 years ago
I had no problems with window activation or focus using Windows registry settings 
(Tweak UI / X-Mouse) to get the same effect. So it's an interaction between 
Mozilla and ReflectionX; there's no general problem with focus.

Tweak UI has the testability advantage of not costing several hundred $. I'm 
afraid I have to bounce this one and hope some helpful Mozilla hack with their 
very own copy of Reflection can pick it up.
Assignee: danm → nobody

Updated

17 years ago
Summary: Dialog undismissable when their focus is stolen → Dialogs can't be refocused after losing focus by ReflectionX

Updated

16 years ago
You need to log in before you can comment on or make changes to this bug.