[WebAPI] WebSMS: Develop a test to verify receiving a multi-part SMS

RESOLVED FIXED in Firefox 18

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rwood, Assigned: rwood)

Tracking

unspecified
mozilla20
All
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(firefox18 fixed, firefox19 fixed, firefox20 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Develop a WebSMS test (marionette, for the emulator) that will exercise receiving a multi-part SMS message (> 160 characters).

Note that a test for sending a multi-part SMS already exists in test_outgoing.js.
(Assignee)

Comment 1

5 years ago
Created attachment 680149 [details] [diff] [review]
Patch for 810083
Attachment #680149 - Flags: review?(jgriffin)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 806811
(Assignee)

Comment 3

5 years ago
The patch that I attached is still a valid test and was waiting for review when this issue was marked as duplicate, so reopening this issue so the patch can be reviewed and submitted.  This patch is just for a basic incoming multi-part SMS, bug 806811 is to test the maximum number of multi-part incoming and outgoing messages.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attachment #680149 - Flags: review?(jgriffin) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/3eb1e8651376
Whiteboard: [automation-needed-in-aurora][automation-needed-in-beta]
Target Milestone: --- → mozilla20

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/3eb1e8651376
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/f7d72ef613c0
https://hg.mozilla.org/releases/mozilla-beta/rev/0eecff00cdad
status-firefox18: --- → fixed
status-firefox19: --- → fixed
status-firefox20: --- → fixed
Whiteboard: [automation-needed-in-aurora][automation-needed-in-beta]
You need to log in before you can comment on or make changes to this bug.