Closed Bug 810307 Opened 7 years ago Closed 7 years ago

Add-on manager xpcshell test failures

Categories

(Toolkit :: Add-ons Manager, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 810617

People

(Reporter: jimm, Unassigned)

References

Details

Attachments

(1 file)

Various failures in the add-on manager. 


TEST-UNEXPECTED-FAIL | toolkit\mozapps\extensions\test\xpcshell\test_dss.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/xpcshell/head_addons.js | true == false - See following stack:

^ light weight theme manager issue with _setCurrentTheme incorrectly requiring a restart after installing a new theme.

TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/xpcshell/test_startup.js | false == true - See following stack:

^ gCachePurged doesn't get set during test6.

TEST-UNEXPECTED-FAIL | toolkit\mozapps\extensions\test\xpcshell\test_theme.js | test failed (with xpcshell return code: 0), see following log:

^ light weight theme manager issue with _setCurrentTheme.

https://tbpl.mozilla.org/php/getParsedLog.php?id=16875103&tree=Elm&full=1#error15
Blocks: 789335
No longer blocks: metro-build
Also, test_backgroundupdate.js, which is currently disabled on elm to get complete test runs, hangs.
TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/xpcshell/test_startup.js | false == true - See following stack:

^ gCachePurged doesn't get set during test6.

This failure is caused by an assumption in the test about the presence of the default theme extension. Should be pretty easy to work around.
Comment on attachment 680114 [details] [diff] [review]
test_backgroundupdate fix

Review of attachment 680114 [details] [diff] [review]:
-----------------------------------------------------------------

Er, hmm. If that fixes it, it kinda makes it look like there's a real bug there (not just the test needing a fix).
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 810617
You need to log in before you can comment on or make changes to this bug.