Closed Bug 810509 Opened 7 years ago Closed 7 years ago

stub installer ping does not happen if user cancels while it is downloading

Categories

(Firefox :: Installer, defect)

x86
All
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 19
Tracking Status
firefox17 --- unaffected
firefox18 --- verified
firefox19 --- verified

People

(Reporter: jbecerra, Assigned: robert.strong.bugs)

References

Details

(Whiteboard: [stub+])

Attachments

(1 file)

The stub installer sends a ping when it succeeds installing Firefox. However, the stub installer should also be sending a ping if it is initiated but cancelled during the downloading phase.

It looks like that latter part has been implemented and it should be sending a ping when the user cancels mid-download but it isn't. See https://bugzilla.mozilla.org/show_bug.cgi?id=804231#c5

You only get a ping if the installation is completed.

Steps:
1. Download and install Fiddler to monitor network traffic: https://fiddler2.com/fiddler2/
2. Download the stub installer from the latest mozilla central directory: http://is.gd/pQB2d5
3. Run Fiddler
4. Run the stub installer. When the download stops going back and forth and starts moving steadily to the right, click the Cancel button.

Expected: You should see a ping in Fiddler pointing to download-stats...

Actual: No ping.
Whiteboard: [stub]
Attached patch Patch rev1Splinter Review
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #680295 - Flags: review?(netzen)
Comment on attachment 680295 [details] [diff] [review]
Patch rev1

In case Jim can get to this before Brian.

Basically, the existing download needs to be cancelled before making the new request.
Attachment #680295 - Flags: review?(jmathies)
Comment on attachment 680295 [details] [diff] [review]
Patch rev1

Review of attachment 680295 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #680295 - Flags: review?(netzen) → review+
Attachment #680295 - Flags: review?(jmathies)
Awesome job on finding this case btw Juan.
(In reply to Brian R. Bondy [:bbondy] from comment #5)
> Awesome job on finding this case btw Juan.
+1
https://hg.mozilla.org/mozilla-central/rev/999a815a4a6d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Comment on attachment 680295 [details] [diff] [review]
Patch rev1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 802734
User impact if declined: Stub installer pings won't be received for the case where the user cancels
Testing completed (on m-c, etc.): Tested locally
Risk to taking this patch (and alternatives if risky): Minimal especially since the ping happens after all other install operations so this change should not interfere with the install process
String or UUID changes made by this patch: none
Attachment #680295 - Flags: approval-mozilla-aurora?
Attachment #680295 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [stub] → [stub+]
These are the testing results with the latest nightly stub installer. We now get pings after installation, when Cancelling during download as well as immediately after, and we get no pings if the option to send information is unchecked. You also don't get a ping if the user starts up the stub installer but does not initiate the Install and just cancels. Here are some sample pings:

After successful installation with existing nightly:
GET /stub/v1/nightly/en-US/0/2/95/19961/1/1/ HTTP/1.1
User-Agent: NSIS InetBgDL (Mozilla)
Host: download-stats.mozilla.org
Connection: Keep-Alive

No nightly previously installed, Cancel during downloading:
GET /stub/v1/nightly/en-US/10/0/21/16908/1/0/ HTTP/1.1
User-Agent: NSIS InetBgDL (Mozilla)
Host: download-stats.mozilla.org
Connection: Keep-Alive

No nightly previously installed, Cancel before downloading:
GET /stub/v1/nightly/en-US/10/0/432/0/1/0/ HTTP/1.1
User-Agent: NSIS InetBgDL (Mozilla)
Host: download-stats.mozilla.org
Connection: Keep-Alive

No existing nightly, Cancel immediately after clicking on "install" (example 2):
GET /stub/v1/nightly/en-US/10/0/0/0/1/0/ HTTP/1.1
User-Agent: NSIS InetBgDL (Mozilla)
Host: download-stats.mozilla.org
Connection: Keep-Alive
Also, this is the ping I get when I run the stub installer, while a version of the Nightly is already running. This was the only case I could find quickly to test that the ping was sent when there was a failure. 

GET /stub/v1/nightly/en-US/0/1/12/19961/1/1/ HTTP/1.1
User-Agent: NSIS InetBgDL (Mozilla)
Host: download-stats.mozilla.org
Connection: Keep-Alive
If someone could land this on aurora I'd appreciate it... I am having ISP troubles atm
I'll land it now
Keywords: verifyme
QA Contact: jsmith
Verified on trunk, aurora, and beta.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.