Collapsible table (wikipedia) not rendered correctly

RESOLVED FIXED in Firefox 18

Status

()

--
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: bugzilla_acct_1959, Assigned: dbaron)

Tracking

({regression, testcase})

18 Branch
mozilla20
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17 unaffected, firefox18+ verified, firefox19+ verified, firefox20+ verified, b2g18 fixed)

Details

Attachments

(6 attachments)

(Reporter)

Description

6 years ago
Created attachment 680356 [details]
Table Incorrectly Rendered

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121109030635

Steps to reproduce:

Go to http://en.wikipedia.org/wiki/Hundred_of_Hoo_Railway (Nightly 19.0a1 2012-11-09)


Actual results:

Collapsible table (showing diagram of railway line) has too much whitespace to right of table. When browser window is narrow, table intrudes over text.
Error not present on current Firefox (16.0.2).


Expected results:

Incorrect whitespace shouldn't appear - should render as in 16.0.2

Comment 1

6 years ago
(In reply to Jonathan from comment #0)
> Incorrect whitespace shouldn't appear - should render as in 16.0.2

I observe the same behavior with FF16 and FF19, the table "enters" into the text when the browser window is reduced horizontaly.
Thank you good fellows!
I confirm this wrong behavior on FF 19.0a1 (2012-11-12) on Win7 x64 when reducing the browser dimensions.
Setting the resolution to NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

6 years ago
Created attachment 693057 [details]
simplified testcase

I've reduced the problem to the attached testcase - it seems to be the combination of colspan and width=100% that causes each spanned column to be as wide as the content. Firefox 17, IE 9 and Chrome 23 fit the table to the text; in Firefox 18 the table is twice as wide.
(Reporter)

Updated

6 years ago
Version: 19 Branch → 18 Branch
(Reporter)

Comment 4

6 years ago
Thanks Stuart, confirmed in Firefox 18 also - I've changed the branch to reflect this.
Severity: normal → major

Updated

6 years ago
Attachment #693057 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 5

6 years ago
Also upped severity to major - Firefox 18 due for release w/c 6 Jan and this bug must affect a lot of webpages.

Comment 6

6 years ago
Regression range:

m-c
good=2012-09-07
bad=2012-09-08
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=36427d4b2cf6&tochange=1d4fc0c60063

Need more investigation.
status-firefox17: --- → unaffected
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
Keywords: regression, regressionwindow-wanted, testcase
I suspect bug 734569 but I'm currently bisecting
Component: Untriaged → Layout: Tables
Product: Firefox → Core

Comment 8

6 years ago
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/0afb00f99006
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120907155516
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3916c4ac4a81
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120907160717
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0afb00f99006&tochange=3916c4ac4a81

Suspected :Bug 734569
Blocks: 734569
Keywords: regressionwindow-wanted
The first bad revision is:
changeset:   104624:1ead7ec99cea
user:        L. David Baron <dbaron@dbaron.org>
date:        Fri Sep 07 15:57:06 2012 -0700
summary:     Distribute the width of column-spanning cells to columns with nothi
ng in them, like we do for final table widths.  (Bug 734569)  r=dholbert

Updated

6 years ago
Assignee: nobody → dbaron
tracking-firefox18: ? → -
tracking-firefox19: ? → +
tracking-firefox20: ? → +
Considering where we are in the FF18 and this is not a very severe issue "wontfix" for FF18 & tracking it fir FF19 and above.:Dbaron, can you please help investigate  ?

Updated

6 years ago
status-firefox18: --- → wontfix
status-firefox19: --- → affected
status-firefox20: --- → affected
Please don't assign bugs directly to me without sending me email; I'm unlikely to notice.  (Really, I think that's true in general; you shouldn't change the assignee field without making sure that the assignee is actually aware of that.)
Created attachment 694439 [details] [diff] [review]
back out 734569 for beta

For beta I'd like to back out bug 734569.  It's pretty isolated from other changes so it should below risk to go back to the way things used to be; it's also not unlikely other occurrences of this same pattern will show up and break other pages.

(For trunk, patches coming shortly.)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 734569
User impact if declined: bad layout of Web pages
Testing completed (on m-c, etc.): it's our previous behavior
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none
Attachment #694439 - Flags: approval-mozilla-beta?
Comment on attachment 694439 [details] [diff] [review]
back out 734569 for beta

Approving the backout for FF18.Please make sure to perform the backout before Wednesday(12/26) .
Attachment #694439 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Updated

6 years ago
status-firefox18: --- → affected
tracking-firefox18: ? → +
Comment on attachment 694439 [details] [diff] [review]
back out 734569 for beta

At this point I'd also like to take the backout for Aurora.  Same
[Approval Request Comment] as before.
Attachment #694439 - Flags: approval-mozilla-aurora?
OS: Windows 7 → All
Hardware: x86_64 → All
Attachment #697224 - Flags: review?(dholbert) → review+

Updated

6 years ago
Attachment #694439 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/637e063b2055
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-firefox20: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Keywords: verifyme
(In reply to Loic from comment #1)
> the table "enters" into the
> text when the browser window is reduced horizontaly.

This is still reproducible on Nightly 21.0a1 (2013-01-09), FF 19b1 on http://en.wikipedia.org/wiki/Hundred_of_Hoo_Railway, so the problem is not completely solved. See Chrome and Opera behaviors.
Can someone please advise based on comment 23? Should this bug be reopened? Should a follow-up bug be filed?
Yup, this still isn't quite right.

Testing w/ my nightly (2013-01-09), it looks like this part is fixed:
(In reply to Jonathan from comment #0)
> Collapsible table (showing diagram of railway line) has too much whitespace
> to right of table.

But this part is broken:
> When browser window is narrow, table intrudes over text.

We should probably track that in a followup, rather than trying to fix both issues in this bug.
Blocks: 833788
(In reply to Daniel Holbert [:dholbert] from comment #25)
> Testing w/ my nightly (2013-01-09), it looks like this part is fixed:
> (In reply to Jonathan from comment #0)
> > Collapsible table (showing diagram of railway line) has too much whitespace
> > to right of table.
Verified fixed FF 18.0.1, 19b2, 20.0a2 (2013-01-22)

> But this part is broken:
> > When browser window is narrow, table intrudes over text.
> 
> We should probably track that in a followup, rather than trying to fix both
> issues in this bug.
bug 833788 filed
status-firefox18: fixed → verified
status-firefox19: fixed → verified
status-firefox20: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.