The search window's default columns fix has regressed.

VERIFIED FIXED in mozilla0.9.7

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: Suresh)

Tracking

({regression})

Trunk
mozilla0.9.7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+]Have Fix, URL)

Attachments

(1 attachment)

Build ID:  2001051504, all OSs.

Summary: The search window's default columns fix has regressed.

Rather than opening a bug that *was* fixed and verified, I'm filing this.  

As a regression from bug 76216:

"The default columns (and order) in the Results area should be: Thread, Subject,
Sender, Date, Location, Column Widget."

Something has broken, and my functions either aren't getting called, or are useless.

http://lxr.mozilla.org/seamonkey/source/mailnews/base/search/resources/content/SearchDialog.js

I will add dump statements and build debug, but I bet this is beyond my scope.
Currently, we are showing all of the columns again (so this is a total
regression).  Since bug 76216 was marked nsbeta1+, I'm nominating this, too.
Keywords: nsbeta1, regression
QA Contact: esther → laurel
the thread column should not be in the search dialog.

if the spec says that, can log a bug on jglick to fix it?

weren't there a bunch of dialog problems today?

I'm not seeing this in my linux build.
Sorry, I just cut and pasted from the other bug. 
http://www.mozilla.org/mailnews/specs/search/ is correct, I believe.  My fault.
 And I'm not sure about bunch of dialog problems (although I heard something
broke in nav, too).

Comment 4

17 years ago
reassigning to suresh. Moving to 0.9.2, but if this got fixed before Friday that
would be great.
Assignee: naving → suresh
Priority: -- → P3
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.2
stephend, did you see this problem on a new profile or on your existing profile?
On both, and you'll also notice this isn't totally broken.  If it was, we
wouldn't be hiding by default the other columns.  Really, what has regressed
here is the attribute setting of "ignoreincolumnpicker".
I see this too, now. 

outlinerBindings.xml became outliner.xml on 5/11

it doesn't look like all the changes to outlinerBindings.xml made it into the 
new file.

hewitt?
(Assignee)

Comment 8

17 years ago
Created attachment 36574 [details] [diff] [review]
patch attached. hewitt can you review? Thanks!

Comment 9

17 years ago
sr=hewitt on the patch, but, you might want to replace those tabs with spaces
r=sspitzer

make sure to fix the tabs problem before checking in.

Comment 11

17 years ago
Sorry to jump in late...

Suresh, how about this:

 if (firstTime) {
+ if (currCol.getAttribute("hidden") != "true") {

becomes this:

if (firstTime && currCol.getAttribute("hidden") != "true") {

after that. r=hwaara

Updated

17 years ago
Whiteboard: [nsbeta1+] → [nsbeta1+]Have Fix

Comment 12

17 years ago
moving to 0.9.3.  Please hold onto the fix in case we can get it in later.
Target Milestone: mozilla0.9.2 → mozilla0.9.3
(Assignee)

Comment 13

17 years ago
-> 0.9.4
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.7

Updated

17 years ago
Blocks: 104166

Comment 14

17 years ago
nominating
Keywords: nsbeta1

Comment 15

17 years ago
so this is ready to go and all we're waiting for is a green light?
(Assignee)

Comment 16

17 years ago
Looks like this is fixed...:)
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 17

17 years ago
Looks OK to me using dec13 commercial trunk builds.
Label column is not displayed by default but is in the available choices in the
search results's column widget, covered by bug 107878.
Marking this bug verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.