gUM - Trying to request audio off of one device, stopping the audio, then requesting audio on a different device - audio stream does not start up

RESOLVED DUPLICATE of bug 811695

Status

()

Core
WebRTC: Audio/Video
P1
normal
RESOLVED DUPLICATE of bug 811695
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [getUserMedia][blocking-gum+])

(Reporter)

Description

6 years ago
Steps:

1. Go to https://people.mozilla.com/~anarayanan/webrtc/gum_test.html with a USB mic headset and a internal mic setup
2. Request audio with your internal mic
3. Select stop after the audio stream starts playing
4. Request audio again with your USB headset

Expected:

The audio stream should start using your USB headset as the mic.

Actual:

The audio stream does not start. Killing the tab, reloading the page, or even opening up a new page with the contents to request audio off of the USB headset will continue to fail. The only work-around is to restart your browser to be able to use the other input audio source.
Verified on Nightly Win32; building a debug build to test.

Updated

6 years ago
Duplicate of this bug: 803720
(Reporter)

Updated

6 years ago
Version: unspecified → Trunk
(Reporter)

Updated

6 years ago
Priority: -- → P1
Whiteboard: [getUserMedia][blocking-gum+]
The problem here is the 127.0.0.1 socket that gets reused.  Solved by getting rid of the socket in bug 811695
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 811695
You need to log in before you can comment on or make changes to this bug.