Closed Bug 811012 Opened 8 years ago Closed 8 years ago

Allow forceAuthentication parameter to request for whitelisted Marketplace

Categories

(Cloud Services :: Server: Identity, defect)

defect
Not set
normal

Tracking

(firefox18 fixed, firefox19 fixed)

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: ozten, Assigned: jedp)

References

Details

Attachments

(1 file)

We've added a forceAuthentication parameter to navigator.id.request. It is set to a boolean value and when true causes the shim's dialog to force the user to re-enter their credentials.

The only native task currently is to:
1) Ensure the value flows through via postMessage API
2) Limits callers to Marketplace via whitelist
Blocks: 808831
Ben wants to remove #2.
For a gecko patch, I think this may be sufficient?
Attachment #680965 - Flags: review?(benadida)
To clarify my patch a little: It is just tests to confirm that the parameter is passed along.  I think the problem is solved on the gecko side by Bug 804932, "pass arbitrary options."
Comment on attachment 680965 [details] [diff] [review]
pass the forceAuthentication flag from the RP to the shim

Review of attachment 680965 [details] [diff] [review]:
-----------------------------------------------------------------

awesome. A patch with just tests. "The code was always forward-compatible. We're just making sure it stays that way."
Attachment #680965 - Flags: review?(benadida) → review+
(In reply to Ben Adida [:benadida] from comment #4)
> Comment on attachment 680965 [details] [diff] [review]
> pass the forceAuthentication flag from the RP to the shim
> 
> Review of attachment 680965 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> awesome. A patch with just tests. "The code was always forward-compatible.
> We're just making sure it stays that way."

Thank you.  Yes, that is the idea!
nb: Checkin must wait until Bug 804932 lands
https://hg.mozilla.org/mozilla-central/rev/9771925bee9e
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
This needs a bb+ for the patch to be uplifted into beta
Blocks: basecamp-id
blocking-basecamp: --- → ?
blocking-basecamp: ? → ---
Comment on attachment 680965 [details] [diff] [review]
pass the forceAuthentication flag from the RP to the shim

[Approval Request Comment]
Bug caused by (feature/regressing bug #): feature; these are unit tests
User impact if declined: native identity features will not be fully tested
Testing completed (on m-c, etc.): the patch is only tests
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none
Attachment #680965 - Flags: approval-mozilla-beta?
(In reply to Jed Parsons [:jparsons] from comment #9)
> This needs a bb+ for the patch to be uplifted into beta

Sorry, no it doesn't.  Requested beta approval for patch.
Attachment #680965 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Blocks: 822491
You need to log in before you can comment on or make changes to this bug.