DMD flags double-report of CSS data (allocated at nsCSSStyleSheet::AppendStyleRule)

RESOLVED DUPLICATE of bug 811021

Status

()

RESOLVED DUPLICATE of bug 811021
6 years ago
6 years ago

People

(Reporter: justin.lebar+bug, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
This is in the gallery app in a B2G build with bug 768901 fixed.  See bug 811021 comment 0 for instructions about getting photos into the gallery app on desktop-Linux-B2G.

==16799== Double report of heap block 0x18FB9960:
==16799==  Allocated
==16799==    at 0x402B4A1: realloc (vg_replace_malloc.c:662)
==16799==    by 0x603D9AB: nsVoidArray::SizeTo(int) (nsVoidArray.cpp:166)
==16799==    by 0x603DB4C: nsVoidArray::GrowArrayBy(int) (nsVoidArray.cpp:263)
==16799==    by 0x603DE17: nsVoidArray::InsertElementAt(void*, int) (nsVoidArray.cpp:425)
==16799==    by 0x603AC9E: nsCOMArray_base::InsertObjectAt(nsISupports*, int) (nsCOMArray.cpp:49)
==16799==    by 0x51C48FE: nsCOMArray_base::AppendObject(nsISupports*) (nsCOMArray.h:53)
==16799==    by 0x54ECA05: nsCOMArray<mozilla::css::Rule>::AppendObject(mozilla::css::Rule*) (nsCOMArray.h:229)
==16799==    by 0x5501CFC: nsCSSStyleSheet::AppendStyleRule(mozilla::css::Rule*) (nsCSSStyleSheet.cpp:1470)
==16799==  Previously reported by 'windows'
==16799==    at 0x58BE36E: DOMStyleMallocSizeOf(void const*) (nsWindowMemoryReporter.cpp:108)
==16799==    by 0x603E1F5: nsVoidArray::SizeOfExcludingThis(unsigned long (*)(void const*, unsigned long (*)(void const*), void*), unsigned long (*)(void const*), void*) const (nsVoidArray.cpp:749)
==16799==    by 0x550092F: nsCSSStyleSheetInner::SizeOfIncludingThis(unsigned long (*)(void const*)) const (nsCSSStyleSheet.cpp:1006)
==16799==    by 0x550089A: nsCSSStyleSheet::SizeOfIncludingThis(unsigned long (*)(void const*)) const (nsCSSStyleSheet.cpp:874)
==16799==    by 0x603E24E: SizeOfElementIncludingThisEnumerator(void const*, void*) (nsVoidArray.cpp:737)
==16799==    by 0x603E14E: nsVoidArray::EnumerateForwards(bool (*)(void const*, void*), void*) const (nsVoidArray.cpp:704)
==16799==    by 0x603E227: nsVoidArray::SizeOfExcludingThis(unsigned long (*)(void const*, unsigned long (*)(void const*), void*), unsigned long (*)(void const*), void*) const (nsVoidArray.cpp:755)
==16799==    by 0x5603391: nsDocument::DocSizeOfExcludingThis(nsWindowSizes*) const (nsDocument.cpp:9648)
==16799==  Now reported by 'windows'
==16799==    at 0x58BE36E: DOMStyleMallocSizeOf(void const*) (nsWindowMemoryReporter.cpp:108)
==16799==    by 0x603E1F5: nsVoidArray::SizeOfExcludingThis(unsigned long (*)(void const*, unsigned long (*)(void const*), void*), unsigned long (*)(void const*), void*) const (nsVoidArray.cpp:749)
==16799==    by 0x550092F: nsCSSStyleSheetInner::SizeOfIncludingThis(unsigned long (*)(void const*)) const (nsCSSStyleSheet.cpp:1006)
==16799==    by 0x550089A: nsCSSStyleSheet::SizeOfIncludingThis(unsigned long (*)(void const*)) const (nsCSSStyleSheet.cpp:874)
==16799==    by 0x603F934: SizeOfEntryExcludingThisEnumerator(PLDHashTable*, PLDHashEntryHdr*, unsigned int, void*) (pldhash.cpp:773)
==16799==    by 0x603F80F: PL_DHashTableEnumerate (pldhash.cpp:717)
==16799==    by 0x603F901: PL_DHashTableSizeOfExcludingThis (pldhash.cpp:787)
==16799==    by 0x54D8838: nsBaseHashtable<mozilla::URIPrincipalAndCORSModeHashKey, nsRefPtr<nsCSSStyleSheet>, nsCSSStyleSheet*>::SizeOfExcludingThis(unsigned long (*)(mozilla::URIPrincipalAndCORSModeHashKey*, nsRefPtr<nsCSSStyleSheet> const&, unsigned long (*)(void const*), void*), unsigned long (*)(void const*), void*) const (nsBaseHashtable.h:288)
(Reporter)

Comment 1

6 years ago
Actually...looking through the DMD log, this is probably a dupe of bug 811021.  There are a lot of double-reported CSS fields.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 811021
You need to log in before you can comment on or make changes to this bug.