Last Comment Bug 811132 - Avoid some wasted space by making XPT arena chunks bigger.
: Avoid some wasted space by making XPT arena chunks bigger.
Status: RESOLVED FIXED
[MemShrink]
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: mozilla19
Assigned To: Nicholas Nethercote [:njn]
:
Mentors:
Depends on:
Blocks: slim-fast
  Show dependency treegraph
 
Reported: 2012-11-12 15:57 PST by Nicholas Nethercote [:njn]
Modified: 2012-11-13 17:06 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Avoid some wasted space by making XPT arena chunks bigger. (952 bytes, patch)
2012-11-12 15:57 PST, Nicholas Nethercote [:njn]
khuey: review+
justin.lebar+bug: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2012-11-12 15:57:11 PST
The XPT arena chunk size is currently 1 KiB.  I experimented with making it 
bigger, to see if it reduced the size of "explicit/xpti-working-set".

chunk size      desktop64       b2g-desktop64
----------      ---------       -------------
  1 KiB         1,702,096 B     1,639,632 B 
  4 KiB         1,618,128 B     1,560,784 B
  8 KiB         1,581,264 B     1,532,112 B
 16 KiB         1,573,072 B     1,523,920 B
 32 KiB         1,573,072 B     1,507,536 B
 64 KiB         1,605,840 B     1,540,304 B

The best size was 32 KiB for both cases.
Comment 1 Nicholas Nethercote [:njn] 2012-11-12 15:57:40 PST
Created attachment 680847 [details] [diff] [review]
Avoid some wasted space by making XPT arena chunks bigger.

In this patch I've used 16 KiB because the allocation sizes are a bit smaller
on 32-bit (e.g. bug 802446 says that on b2g xpti-working-set is currently
1,152,128 bytes).  So I'm guessing this will be roughly a 70--80 KiB
per-process win on b2g, at least until bug 799658 is done.
Comment 2 Justin Lebar (not reading bugmail) 2012-11-12 16:12:44 PST
Comment on attachment 680847 [details] [diff] [review]
Avoid some wasted space by making XPT arena chunks bigger.

Simple change, beneficial on desktop even.  a=me
Comment 3 Nicholas Nethercote [:njn] 2012-11-12 16:17:40 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/2ee6655b6da1
Comment 4 Ed Morley [:emorley] 2012-11-13 09:32:08 PST
https://hg.mozilla.org/mozilla-central/rev/2ee6655b6da1
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-11-13 17:06:28 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/4507fdd47ab2

Note You need to log in before you can comment on or make changes to this bug.