Closed Bug 811207 Opened 9 years ago Closed 9 years ago

[QAC generated] Nightly hangs when loading in modern while running Windows 8 virtual machine

Categories

(Firefox for Metro Graveyard :: General, defect)

x86
Windows 8.1
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 844954

People

(Reporter: mneuman1, Unassigned)

References

Details

(Keywords: hang, modern, Whiteboard: DirectX?)

Crash Data

Attachments

(1 file)

Steps to Reproduce
--------------------------------------
1. Load up Windows 8 in VMware Workstation 9.1
2. Select Nightly (modern)
3. Will show loading screen for a while then back to start menu

What should have happened:
---------------------------------------
Loaded nightly



What actually happened:
----------------------------------------
crashed

{
  "application": {
    "name": "Firefox",
    "version": "19.0a1",
    "userAgent": "Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0",
    "supportURL": "http://support.mozilla.org/1/firefox/19.0a1/WINNT/en-US/"
  },
  "modifiedPreferences": {
    "browser.cache.disk.capacity": 358400,
    "browser.cache.disk.smart_size.first_run": false,
    "browser.cache.disk.smart_size.use_old_max": false,
    "browser.cache.disk.smart_size_cached_value": 358400,
    "browser.places.smartBookmarksVersion": 4,
    "browser.startup.homepage_override.buildID": "20121112040206",
    "browser.startup.homepage_override.mstone": "19.0a1",
    "extensions.lastAppVersion": "19.0a1",
    "network.cookie.prefsMigrated": true,
    "places.history.expiration.transient_current_max_pages": 104858,
    "places.database.lastMaintenance": 1352784059,
    "plugin.disable_full_page_plugin_for_types": "application/pdf",
    "privacy.sanitize.migrateFx3Prefs": true,
    "security.warn_viewing_mixed": false
  },
  "graphics": {
    "numTotalWindows": 1,
    "numAcceleratedWindows": 0,
    "windowLayerManagerType": "Basic",
    "numAcceleratedWindowsMessage": [
      "blockedGfxCard"
    ],
    "adapterDescription": "VMware SVGA 3D",
    "adapterVendorID": "0x15ad",
    "adapterDeviceID": "0x0405",
    "adapterRAM": "128",
    "adapterDrivers": "vm3dum64 vm3dum vm3dgl64 vm3dgl",
    "driverVersion": "7.14.1.1211",
    "driverDate": "10-3-2012",
    "adapterDescription2": "",
    "adapterVendorID2": "",
    "adapterDeviceID2": "",
    "adapterRAM2": "",
    "adapterDrivers2": "",
    "driverVersion2": "",
    "driverDate2": "",
    "isGPU2Active": false,
    "direct2DEnabled": false,
    "directWriteEnabled": false,
    "directWriteVersion": "6.2.9200.16384",
    "direct2DEnabledMessage": [
      "blockedGfxCard"
    ],
    "webglRendererMessage": [
      "blockedGfxCard"
    ],
    "info": {
      "AzureCanvasBackend": "cairo",
      "AzureFallbackCanvasBackend": "none",
      "AzureContentBackend": "none"
    }
  },
  "javaScript": {
    "incrementalGCEnabled": true
  },
  "accessibility": {
    "isActive": true,
    "forceDisabled": 0
  },
  "libraryVersions": {
    "NSPR": {
      "minVersion": "4.9.3",
      "version": "4.9.3"
    },
    "NSS": {
      "minVersion": "3.14.0.1 Basic ECC",
      "version": "3.14.0.1 Basic ECC"
    },
    "NSSUTIL": {
      "minVersion": "3.14.0.1",
      "version": "3.14.0.1"
    },
    "NSSSSL": {
      "minVersion": "3.14.0.1 Basic ECC",
      "version": "3.14.0.1 Basic ECC"
    },
    "NSSSMIME": {
      "minVersion": "3.14.0.1 Basic ECC",
      "version": "3.14.0.1 Basic ECC"
    }
  },
  "userJS": {
    "exists": false
  },
  "extensions": []
}
Keywords: crash, modern
Desktop browser works fine.
Can you provide the crash ID from about:crashes in any other Firefox?
Severity: normal → critical
Flags: needinfo?(mneuman1)
OS: Windows XP → Windows 8 Metro
Product: Firefox → Firefox for Metro
Version: 3.5 Branch → Trunk
cd288e7e-3718-42b5-bc8e-82af4bfca435-browser11/14/201212:35 AMcd288e7e-3718-42b5-bc8e-82af4bfca43511/14/201212:35 AM
Flags: needinfo?(mneuman1)
sorry about that. this is cleaner:


cd288e7e-3718-42b5-bc8e-82af4bfca435-browser

cd288e7e-3718-42b5-bc8e-82af4bfca435
These crash reports haven't been submitted (no *monthday* at the end). Try to click them.
information from copying and pasting weren't formatted well. my previous comment has the actual crash report id. The screen shot has them, along with the date submitted.
newer
bp-hr-20121114-4a717409-4001-4adb-9be7-c1ea23115c86    11/14/20126:57 PM
The crash report URL is: https://crash-analysis.mozilla.com/hang-reports/2012/11-14/hr-20121114-4a717409-4001-4adb-9be7-c1ea23115c86.html
Are you sure it's about your current crash because it's a Flash hang and your home page is about:home with no Flash content. See bug 797116.
Crash Signature: [@ hang | GetModuleHandleExW]
Keywords: crashhang
Summary: [QAC generated] Nightly crashes when loading in modern while running Windows 8 virtual machine → [QAC generated] Nightly hangs when loading in modern while running Windows 8 virtual machine
It probably is not. I've clicked on nightly for modern many times, but it doesn't produce any new crash reports. I've uninstalled flash and set my homepage to blank as a precaution as well
My guess is that this is related to DirectX.  DirectX 10 is required to use Firefox for the modern UI.  Eventually, attempting to launch Firefox for modern UI will simply launch desktop Firefox (see bug 807669) but for now it just crashes.  Can you verify that DirectX 10 is supported on your VM?
(In reply to mneuman1 from comment #9)
> It probably is not. I've clicked on nightly for modern many times, but it
> doesn't produce any new crash reports. I've uninstalled flash and set my
> homepage to blank as a precaution as well

Desktop and metro have separate profiles, so desktop doesn't list metrofx crash ids. We're working improving report submission to get at startup crash reports.
Some of the steps are a bit hackish, but we do have prelim startup diagnosing steps here - 

https://wiki.mozilla.org/Firefox/Windows_8_Integration#Diagnosing_Startup_Problems
Whiteboard: DirectX?
Please re-open if this still happens for you with today's Nightly build. I think this is a duplicate of bug 844954.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 844954
Blocks: 855294
No longer blocks: metrov1triage
I try Firefox for Metro on Windows 8.1 in VirtualBox 4.3.2.
And I have the same problem with comment 0.
Please tell me if any information is needed.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.