If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

startup crash in js::types::TypeScript::destroy with McAfee

RESOLVED DUPLICATE of bug 803460

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 803460
5 years ago
4 years ago

People

(Reporter: Usul, Unassigned)

Tracking

({crash, topcrash-thunderbird})

17 Branch
x86
Windows NT
crash, topcrash-thunderbird
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tbird topcrash][startupcrash], crash signature)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-4ee5a531-62a2-4547-86b1-c78992121109 .
============================================================= 
 	Source
0 	mozjs.dll 	js::types::TypeScript::destroy 	js/src/jsinfer.cpp:6114
1 	mozjs.dll 	JSScript::finalize 	js/src/jsscript.cpp:1797
2 	mozjs.dll 	js::gc::Arena::finalize<JSScript> 	js/src/jsgc.cpp:348
3 	mozjs.dll 	js::gc::FinalizeTypedArenas<JSScript> 	js/src/jsgc.cpp:412
4 	mozjs.dll 	BeginSweepPhase 	js/src/jsgc.cpp:3762
5 	mozjs.dll 	IncrementalCollectSlice 	js/src/jsgc.cpp:4217
6 	mozjs.dll 	GCCycle 	js/src/jsgc.cpp:4395
7 	mozjs.dll 	Collect 	js/src/jsgc.cpp:4503
8 	mozjs.dll 	js::GCSlice 	js/src/jsgc.cpp:4541
9 	mozjs.dll 	js::IncrementalGC 	js/src/jsfriendapi.cpp:171
10 	xul.dll 	nsJSContext::GarbageCollectNow 	dom/base/nsJSEnvironment.cpp:2921
11 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:473
12 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:556
13 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:624
14 	xul.dll 	NS_ProcessNextEvent_P 	objdir-tb/mozilla/xpcom/build/nsThreadUtils.cpp:220
15 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:117
16 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
17 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
18 	xul.dll 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:163
19 	xul.dll 	nsAppShell::Run 	widget/windows/nsAppShell.cpp:232
20 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:273
21 	xul.dll 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3812
22 	xul.dll 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3889
23 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3965
24 	thunderbird.exe 	do_main 	mail/app/nsMailApp.cpp:111
25 	thunderbird.exe 	NS_internal_main 	mail/app/nsMailApp.cpp:200
26 	thunderbird.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:100
27 	thunderbird.exe 	__tmainCRTStartup 	crtexe.c:552
28 	kernel32.dll 	BaseThreadInitThunk 	
29 	ntdll.dll 	__RtlUserThreadStart 	
30 	ntdll.dll 	_RtlUserThreadStart
#16 crash for Thunderbird 17.0.5.
All TB crashes with comments have McAfee installed.

as does the reporter cited in comment 0.  who also has the signature reported in bug 808006

Some say it crashes on shutdown.
others entering password.
Summary: crash in js::types::TypeScript::destroy → crash in js::types::TypeScript::destroy with McAfee
Whiteboard: [tbird topcrash]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 803460
It should be noted, that this signature still is strong for version 17.x (which I didn't say in bug 803460) AND many or most all still list msktbird@mcafee.com in addons.  BOO HISS!

signature does NOT exist for TB24.x (as noted in  bug 803460). Which begs the question, do current versions of McAfee better accommodate TB24?  Or did something change in TB24 such that McAfee doesn't crash?
Summary: crash in js::types::TypeScript::destroy with McAfee → startup crash in js::types::TypeScript::destroy with McAfee
Whiteboard: [tbird topcrash] → [tbird topcrash][startupcrash]
Keywords: topcrash-thunderbird
You need to log in before you can comment on or make changes to this bug.