Closed Bug 811351 Opened 7 years ago Closed 7 years ago

We should call switch_to_frame() on delete_session() for B2G marionette sessions

Categories

(Testing :: Marionette, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox18 fixed, firefox19 fixed)

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: mdas, Assigned: jgriffin)

References

Details

Attachments

(1 file, 1 obsolete file)

In B2G, if you switch into the browser frame and delete your session, then start a new session, you'll still be in the browser frame. I think it might be a good idea to switch back to the top-most frame (system app) when we delete the running session. Thoughts?
Yes, we should definitely do so either in deleteSession or newSession, in marionette-actors.js.
We should put the device back into a state that if a person starts it up again, and dont have defensive code to put them in a known state which they should anyway, then they can start from a good place.

My gut is to switch it back to where it needs to be on deleteSession() but can be swayed either way.
This is a pretty easy fix; we just reset the current frame pointers to null in deleteSession, in both actors and listeners.  This also fixes a typo in resetValues(), which resets the frame pointer in newSession in listeners.  Will run on try before asking for review.
Duplicate of this bug: 811386
Comment on attachment 681198 [details] [diff] [review]
Reset the current frame in deleteSession,

try run was green
Attachment #681198 - Flags: review?(mdas)
Update patch to focus default frames
Attachment #681550 - Flags: review?(mdas)
Attachment #681550 - Flags: review?(mdas) → review+
Assignee: nobody → jgriffin
Attachment #681198 - Attachment is obsolete: true
Attachment #681198 - Flags: review?(mdas)
https://hg.mozilla.org/mozilla-central/rev/f538d7df50f2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Whiteboard: [automation-needed-in-aurora]
You need to log in before you can comment on or make changes to this bug.