IonMonkey: Differential Testing: Getting different output with caller and apply

RESOLVED DUPLICATE of bug 818023

Status

()

--
critical
RESOLVED DUPLICATE of bug 818023
6 years ago
6 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 2 bugs, {regression, testcase})

Trunk
x86_64
Linux
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The following testcase shows different behavior with options ---ion-eager vs. no options on m-c revision 1b0226622e94:


var o = { p:'object' };
function f(obj) {
  return f.caller.p ;
}
function ggg(obj) {
  return f.apply(obj, [obj]);
}
ggg.p = "hello";
print(ggg(o));


$ debug64/js --ion-eager test.js
undefined


$ debug64/js test.js
hello
decoder, can you confirm that this bug is fixed?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818023
You need to log in before you can comment on or make changes to this bug.