Last Comment Bug 811657 - firefox crashes since upgrade to android 4.2
: firefox crashes since upgrade to android 4.2
Status: RESOLVED DUPLICATE of bug 802510
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 16 Branch
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-14 00:49 PST by Andy Burns
Modified: 2012-11-14 03:37 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Andy Burns 2012-11-14 00:49:55 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121005155445

Steps to reproduce:

Upgraded Nexus 7 from Android 4.1.2 to 4.2


Actual results:

Firefox 16 now crashes within a few seconds of use every time, tried upgrading to 17beta, this still crashes, I have seen another Nexus 7 user reporting the same issue after upgrading to android 4.2.


Expected results:

Firefox carried on being awesome
Comment 1 Alex Thompson 2012-11-14 01:09:03 PST
I can confirm this on another Nexus 7 which has just been updated to 4.2 (JOP40C).

Both the latest 17 beta and latest 19 nightly (2012-11-13 1b0226622e94) with a clean profile.

Additionally, the crash helper does not appear so no crash report can be submitted.
Comment 2 Scoobidiver (away) 2012-11-14 01:09:36 PST
It's likely bug 802510.
Can you provide the crash ID from about:crashes or the logcat to confirm?
Comment 3 Alex Thompson 2012-11-14 01:27:30 PST
There's no entry in about:crashes and I can't get a logcat as my device isn't rooted (in android > 4.1 apps can only access their own log). I may be able to get the full logcat with a usb cable, but I don't have any handy at the moment.
Comment 4 Andy Burns 2012-11-14 01:30:23 PST
logcat via USB cable
====================

D/GeckoFavicons(28169): Downloaded favicon successfully for URL = https://addons.mozilla.org/en-US/android/addon/url-fixer/?src=homepagebrowse
D/GeckoFavicons(28169): Saving favicon on browser database for URL = https://addons.mozilla.org/en-US/android/addon/url-fixer/?src=homepagebrowse
D/dalvikvm(28169): GC_CONCURRENT freed 522K, 9% free 9734K/10612K, paused 6ms+9ms, total 72ms
D/GeckoFavicons(28169): Saving favicon URL for URL = https://addons.mozilla.org/en-US/android/addon/url-fixer/?src=homepagebrowse
D/GeckoFavicons(28169): Calling setFaviconUrlForPageUrl() for https://addons.mozilla.org/en-US/android/addon/url-fixer/?src=homepagebrowse
W/dalvikvm(28169): threadid=10: thread exiting with uncaught exception (group=0x40d44930)
E/GeckoAppShell(28169): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 656 ("GeckoBackgroundThread")
E/GeckoAppShell(28169): java.lang.RuntimeException: Buffer not large enough for pixels
E/GeckoAppShell(28169):         at android.graphics.Bitmap.copyPixelsFromBuffer(Bitmap.java:417)
E/GeckoAppShell(28169):         at org.mozilla.gecko.GeckoApp.handleThumbnailData(GeckoApp.java:609)
E/GeckoAppShell(28169):         at org.mozilla.gecko.ScreenshotHandler$1.run(GeckoAppShell.java:2578)
E/GeckoAppShell(28169):         at android.os.Handler.handleCallback(Handler.java:725)
E/GeckoAppShell(28169):         at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoAppShell(28169):         at android.os.Looper.loop(Looper.java:137)
E/GeckoAppShell(28169):         at org.mozilla.gecko.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)
I/Choreographer(28169): Skipped 61 frames!  The application may be doing too much work on its main thread.
D/GeckoFavicons(28169): LoadFaviconTask finished for URL = https://addons.mozilla.org/en-US/android/addon/url-fixer/?src=homepagebrowse (6)
I/GeckoBrowserApp(28169): Favicon successfully loaded for URL = https://addons.mozilla.org/en-US/android/addon/url-fixer/?src=homepagebrowse
I/GeckoBrowserApp(28169): Favicon is for current URL = https://addons.mozilla.org/en-US/android/addon/url-fixer/?src=homepagebrowse
I/GeckoTab(28169): Updated favicon for tab with id: 1
D/Zygote  (  126): Process 28169 terminated by signal (11)
I/ActivityManager(  441): Process org.mozilla.firefox (pid 28169) has died.
I/WindowState(  441): WIN DEATH: Window{418d1440 u0 SurfaceView}
W/ActivityManager(  441): Force removing ActivityRecord{41899138 u0 org.mozilla.firefox/.App}: app died, no saved state
I/WindowState(  441): WIN DEATH: Window{4185f0e0 u0 org.mozilla.firefox/org.mozilla.firefox.App}
W/InputMethodManagerService(  441): Got RemoteException sending setActive(false) notification to pid 28169 uid 10002
D/AndroidRuntime(28284):
D/AndroidRuntime(28284): >>>>>> AndroidRuntime START com.android.internal.os.RuntimeInit <<<<<<
D/AndroidRuntime(28284): CheckJNI is OFF
D/dalvikvm(28284): Trying to load lib libjavacore.so 0x0
D/dalvikvm(28284): Added shared lib libjavacore.so 0x0
D/dalvikvm(28284): Trying to load lib libnativehelper.so 0x0
D/dalvikvm(28284): Added shared lib libnativehelper.so 0x0
D/AndroidRuntime(28284): Calling main entry com.android.commands.am.Am
D/dalvikvm(28284): Note: class Landroid/app/ActivityManagerNative; has 156 unimplemented (abstract) methods
I/AndroidRuntime(28284): VM exiting with result code 1.
W/ActivityManager(  441): Permission Denial: startActivity asks to run as user -2 but is calling from user 0; this requires android.permission.INTERACT_ACROSS_USERS_FULL
Comment 5 Scoobidiver (away) 2012-11-14 03:37:30 PST

*** This bug has been marked as a duplicate of bug 802510 ***

Note You need to log in before you can comment on or make changes to this bug.