Scroll Bar Width is Too Narrow - Uneasily Adjustable

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Lonnie Lee Best, Unassigned)

Tracking

16 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121025212310

Steps to reproduce:

For additional files go here:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1077559


Actual results:

I've been using the Internet since 1993 before and during the first year browsers came out. Back then the scroll bars seemed as wide as your finger.

As time has gone on, screen resolutions have continue to increase, but each time this happens the browsers scroll bar gets more and more narrow on the screen. It seems to maintain its pixel width, but at higher resolutions its physical width continues to narrow.

At this point, I find myself wanting to enjoy higher resolutions, but at the same time, I want things to be bigger at those higher resolutions.

It has finally gotten to the point, that I find the width of scroll bars too narrow, requiring too fine-grained of a mouse-control-effort for simple web page navigation, such as:
1) Clicking the scroll-bar's up button
2) Clicking the scroll-bar's down button
3) Dragging the scroll-bar's slider.

Although a scroll-wheel is a helpful workaround, it remains an issue that the scroll-bar itself continues to require ever increasing fine-grained-effort to use. It is finally gotten to the point that I consider it a cumbersome control.

I suggest doubling its size by default in future updates and releases of Firefox. Or at lease making the scroll-bar easy to scale-adjust its size (without the user having to understand CSS style sheet modification). Perhaps it would be good to make the scroll-bar right-clickable and providing a "Adjust Width" option in its context menu.

Many desktop applications could learn a thing or two from touch screen interfaces. Notice how bluntly (widely) they make their buttons and selectable options. They do it out of necessity because they know a person is going to be using their finger to select that option. However, even with a mouse, the bigger something is, the easier it is to select. Just because a mouse-cursor comes to a fine point, doesn't mean that controls ought to be barely bigger than that point.

I believe we have finally crossed a threshold. While before, we've always been trying to maximize the browser's screen real estate, now we've got plenty of width at higher resolutions, and it is time to increase the width of scrollbars and make them require less fine-grained-mouse-control-effort to use.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: firefox 16.0.2+build1-0ubuntu0.12.10.1
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: lonnie 2197 F.... pulseaudio
 /dev/snd/controlC0: lonnie 2197 F.... pulseaudio
BuildID: 20121025212310
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Channel: Unavailable
Date: Sat Nov 10 22:42:45 2012
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2012-10-19 (23 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
IpRoute:
 default via 192.168.77.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.77.0/24 dev eth0 proto kernel scope link src 192.168.77.246 metric 1
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MarkForUpload: True
PrefSources:
 prefs.js
 [Profile]/extensions/{8f8fe09b-0bd3-4470-bc1b-8cad42b8203a}/defaults/preferences/prefs.js
 [Profile]/extensions/{b9db16a4-6edc-47ec-a1f4-b86292ed211d}/defaults/preferences/prefs-dwhelper.js
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=16.0.2/20121025212310 (In use)
RelatedPackageVersions:
 icedtea-7-plugin 1.3-1ubuntu1.1
 google-talkplugin 3.10.2.0-1
 rhythmbox-mozilla 2.97-1ubuntu5
 totem-mozilla 3.4.3-0ubuntu4
RfKill:

RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

dmi.bios.date: 11/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0P792H
dmi.board.vendor: Dell Inc.
dmi.board.version: A04
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A04
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd11/26/2008:svnDellInc.:pnStudio1737:pvrA04:rvnDellInc.:rn0P792H:rvrA04:cvnDellInc.:ct8:cvrA04:
dmi.product.name: Studio 1737
dmi.product.version: A04
dmi.sys.vendor: Dell Inc.
(Reporter)

Comment 1

5 years ago
I see that I am not alone for requesting this:
http://support.mozilla.org/en-US/questions/814771

Comment 2

5 years ago
I don't really see how this is a firefox bug; firefox respects the scroll bar dimensions specified in the os theme.

You can load a theme with wider scroll bars, and firefox will happily use them.

Updated

5 years ago
Thank you Lonnie for your suggestion. 

Could you please try the suggestion given by Cork?
hey Lonnie, are you there?
Flags: needinfo?(mozilla)
Whiteboard: [closeme]
(Reporter)

Comment 5

5 years ago
My OS doesn't provide themes that will adjust scroll bar widths (Ubuntu 12.10).
Flags: needinfo?(mozilla)

Comment 6

5 years ago
You can modify the gtk theme to your needs.

http://askubuntu.com/questions/94147/how-do-i-make-the-scrollbars-wider
(Reporter)

Comment 7

5 years ago
Thanks for the help, Cork. My OS has no gui for modifying the width, but that link you gave directed me to a text file where I could do it. I'm satisfied.

Comment 8

5 years ago
Resolved per whiteboard and Comment 7
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme]
You need to log in before you can comment on or make changes to this bug.