Closed Bug 811682 Opened 7 years ago Closed 7 years ago

crash in [@ mozalloc_abort | FT_Outline_Decompose]

Categories

(Firefox for Android :: General, defect, critical)

All
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 705641

People

(Reporter: ioana.chiorean, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-ba914018-b56f-4cd5-adbc-bcec32121106 .

No special step, just regular browsing.

============================================================= 
0 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:19
1 	libc.so 	libc.so@0x1bf61 	
2 	dalvik-heap (deleted) 	dalvik-heap @0x75d11f 	
3 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x3098f40 	
4 	org.mozilla.fennec-1.apk 	org.mozilla.fennec-1.apk@0x55bd5f 	
5 	org.mozilla.fennec-1.apk 	org.mozilla.fennec-1.apk@0x128c82e 	
6 	dalvik-heap (deleted) 	dalvik-heap @0xe97f66b 	
7 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x31cb273 	
8 	libxul.so 	FT_Outline_Decompose 	modules/freetype2/src/base/ftoutln.c:233
9 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x118602a 	
10 	dalvik-heap (deleted) 	dalvik-heap @0xb9cff70 	
11 	libxul.so 	nsACString_internal::AppendFunc 	nsTSubstring.h:403
12 	libnspr4.so 	FuncStuff 	prprf.c:1043
13 	libnspr4.so 	fill_n 	prprf.c:205
14 		@0x63 	
15 	libxul.so 	nsACString_internal::ReplaceASCII 	nsTSubstring.cpp:507
16 	libxul.so 	nsACString_internal::AppendFunc 	nsTSubstring.h:403
17 	libnspr4.so 	FuncStuff 	prprf.c:1043
18 	libnspr4.so 	dosprintf 	prprf.c:1028
19 	libnspr4.so 	PR_vsxprintf 	prprf.c:1073
20 		@0x63e9d96e 	
21 	libxul.so 	mozilla::layers::LayerManagerOGL::CreateFBOWithTexture 	LayerManagerOGL.cpp:1357
22 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	ContainerLayerOGL.cpp:225
23 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	ContainerLayerOGL.cpp:263
24 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	ContainerLayerOGL.cpp:263
25 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	ContainerLayerOGL.cpp:263
26 	libxul.so 	mozilla::layers::LayerManagerOGL::Render 	LayerManagerOGL.cpp:949
27 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	LayerManagerOGL.cpp:661
28 	libxul.so 	mozilla::layers::LayerManagerOGL::EndEmptyTransaction 	LayerManagerOGL.cpp:625
29 	libxul.so 	mozilla::layers::CompositorParent::Composite 	CompositorParent.cpp:565
30 	libxul.so 	RunnableMethod<mozilla::layers::CompositorParent, void 	tuple.h:383
31 	libxul.so 	MessageLoop::RunTask 	message_loop.cc:333
32 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	message_loop.cc:341
33 	libxul.so 	MessageLoop::DoWork 	message_loop.cc:441
34 	libxul.so 	base::MessagePumpDefault::Run 	message_pump_default.cc:23
35 	libxul.so 	MessageLoop::RunInternal 	message_loop.cc:215
36 	libxul.so 	MessageLoop::Run 	message_loop.cc:208
37 	libxul.so 	base::Thread::ThreadMain 	thread.cc:156
38 	libxul.so 	ThreadFunc 	platform_thread_posix.cc:39
39 	libc.so 	libc.so@0x12bb2 	
40 	libc.so 	libc.so@0x1230a 	
41 	libEGL.so 	libEGL.so@0x22c3a
Summary: crash in mozalloc_abort → crash in [@ mozalloc_abort | FT_Outline_Decompose]
For aborts, see the abort message and check if there's an already filed bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705641
You need to log in before you can comment on or make changes to this bug.