Closed Bug 811853 Opened 12 years ago Closed 12 years ago

Self-hosted functions are enumerable

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mozillabugs, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

To reproduce, build with the attached patch, use the js shell, and run:

js> for (var p in Array.prototype) print(p)

With current sources, this prints "enumerable", the name of the self-hosted function provided by the patch.

Self-hosted functions, being built-in functions, generally must not be enumerable - see the last paragraph of ES 5.1, clause 15:
http://ecma-international.org/ecma-262/5.1/#sec-15

This regression was introduced somewhere between mozilla-central revisions a76c1f4c4112 (2012-10-17) and dd68409d7810 (2012-10-13).
The last date in the description should be 2012-11-13.
Blocks: 769872
This is probably caused by bug 807228, and should be fixed again once bug 791850 lands.
Depends on: 791850
Fixed by Fix attachment 683832 [details] [diff] [review] from bug 791850
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Keywords: regression
Summary: Regression: Self-hosted functions are enumerable → Self-hosted functions are enumerable
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: