Closed Bug 811944 Opened 7 years ago Closed 7 years ago

Windows builds of B2G fail with "MSVCR100.dll was not found"

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

x86
Windows 7
defect
Not set

Tracking

(firefox18 fixed, firefox19 fixed)

RESOLVED FIXED
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: myk, Assigned: myk)

Details

Attachments

(1 file, 1 obsolete file)

Attached patch patch v1: package CRT (obsolete) — Splinter Review
Windows builds of B2G fail on user-class machines because "MSVCR100.dll was not found."

That's because bug 678195 removed old-style jemalloc, since which "all builds... require the CRT to work on non development environments" (bug 679359, comment 0), but B2G still excludes it from the package if MOZ_MEMORY is defined <https://hg.mozilla.org/mozilla-central/file/df3421b24be8/b2g/installer/package-manifest.in#l68>.

Here's the obvious fix along with a couple other minor changes to make it consistent with the Firefox equivalent.
Attachment #681741 - Flags: review?(mh+mozilla)
Comment on attachment 681741 [details] [diff] [review]
patch v1: package CRT

Review of attachment 681741 [details] [diff] [review]:
-----------------------------------------------------------------

::: b2g/installer/package-manifest.in
@@ +82,5 @@
> +#elif MOZ_MSVC_REDIST == 1700
> +@BINPATH@/msvcp110.dll
> +@BINPATH@/msvcr110.dll
> +#ifdef MOZ_METRO
> +@BINPATH@/vccorlib110.dll

I don't think you need the metro part.
Attachment #681741 - Flags: review?(mh+mozilla) → review+
(In reply to Mike Hommey [:glandium] from comment #1)
> I don't think you need the metro part.

Ok, here's the patch with the metro part removed.  Carrying forward review.  This is the version I'll push to inbound.
Attachment #681741 - Attachment is obsolete: true
Attachment #682055 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/577786665c5e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 682055 [details] [diff] [review]
patch v2: remove metro part

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 678195

User impact if declined: B2G Desktop will fail on Windows machines that don't have the relevant development libraries installed.

Testing completed (on m-c, etc.): Before landing it on inbound, I built with this patch on my Windows 7 machine with MSVC 2010 and then tested the build on both that machine and on a Windows XP machine that doesn't have the CRT installed (and on which previous builds failed with the message "MSVCR100.dll was not found").

The patch landed on central last night, and I verified this morning that today's nightly build of B2G for Windows <https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2012-11-16-03-07-32-mozilla-central/b2g-19.0a1.en-US.win32.zip> includes the necessary DLLs and works as expected.

Risk to taking this patch (and alternatives if risky): Since this is a Windows-only B2G-only fix, it doesn't risk regressing other platforms and apps.  And since the Windows builds didn't work for most people before this fix (because of this bug and others), it doesn't risk regressing almost anything for almost anyone.

String or UUID changes made by this patch: None.
Attachment #682055 - Flags: approval-mozilla-aurora?
Attachment #682055 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.