Pages with meta refresh tags fire after other URL loaded

VERIFIED WORKSFORME

Status

()

Core
Event Handling
P3
normal
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: cpratt, Assigned: rpotts (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Build ID: 1999061409
Platform: Windows NT

To reproduce this bug:

- Go to http://www.bear.net (warning: adult content). Apprunner will load a
page that contains a refresh tag that specifies a 20 second pause before
loading a relative URL:
<META http-equiv="refresh" content="20; URL=/home.tpl">
- Before the 20 seconds are up, manually enter a different URL and press Enter
to load it. (I used Yahoo!).
- Yahoo! will finish loading. However, in a few more seconds, the refresh tag
from the main page at bear.net will kick in and you'll go back to the actual
home page at bear.net (http://www.bear.net/home.tpl).

Expected result would be that you stay at Yahoo!; manually entering a URL
should "break" the refresh process.

I used view-source: to grab the source HTML but when it's served from a local
machine, the problem does not manifest itself.
(Reporter)

Updated

19 years ago
QA Contact: janc → cpratt

Comment 1

19 years ago
I have seen a similar problem.  I type www.excite.com (my personalized page,
which is set to refresh (with a META Refresh) every ten minutes) into the
location bar and hit enter.  After the page loads, I type slashdot.org into the
location bar and hit enter.  If I leave it sitting on the Slashdot page, or even
browsing through the stories, after ten minutes the browser will refresh back to
my Excite page.  Conversely, I have a link to Slashdot on my Excite page.  If I
click this link, I go to slashdot.org, but the page never appears to refresh to
Excite again.  This is running M8 on NT SP4.

Updated

19 years ago
Assignee: joki → rpotts

Comment 2

19 years ago
Rick, did I forget to give you this one before or is it a dupe.  Either way,
here you go.

Comment 3

19 years ago
*** Bug 9821 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

19 years ago
It looks like they removed the meta-refresh tag from this page...  However,
other pages with <META http-equiv="refresh"...> seem to work now...

I think that all of the docloader work fixed the problem :-)
-- rick
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
Sounds good to me. Verifying as WFM.
You need to log in before you can comment on or make changes to this bug.