Javascript doesn't honor values set via Foo.prototype.bar

RESOLVED DUPLICATE of bug 783396

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 783396
5 years ago
5 years ago

People

(Reporter: Raimar Falke, Unassigned)

Tracking

({regression, testcase})

16 Branch
x86_64
Windows 7
regression, testcase
Points:
---

Firefox Tracking Flags

(firefox17-, firefox18-, firefox19-)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 681950 [details]
test.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

Execute the script


Actual results:

hhh.align should have the value 'left'.


Expected results:

Property has undefined value.
http://software.hixie.ch/utilities/js/live-dom-viewer/saved/1914

Uncommenting the this.__proto__ line fixes the issue.
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: Untriaged → JavaScript Engine
Ever confirmed: true
Product: Firefox → Core

Updated

5 years ago
Attachment #681950 - Attachment mime type: text/plain → text/html
Ms2ger, is this a regression?  Regression range?

Comment 3

5 years ago
m-c
good=2012-06-05
bad=2012-06-06
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a7a905fd70d5&tochange=6338a8988917

m-i
good=2012-06-04
bad=2012-06-05
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=778ba119ded6&tochange=f56e2197d9cd
Keywords: regression, regressionwindow-wanted, testcase
Possibly a regression from bug 759978?
tracking-firefox17: --- → ?
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
Keywords: regressionwindow-wanted
Hmm.  My 2012-10-28 nightly shows correct behavior.  So does the 2012-11-14 nightly.  I do see the problem in Firefox 16.

Is this fixed on trunk?

Comment 6

5 years ago
Yes, it's fixed in the latest Nightly too (Win 7). So it's likely a dupe. I should have to test the latest nightly... :/

Comment 7

5 years ago
The test is also misleading in that it hard codes the 'undefined':

    alert("Expected 'left'; get 'undefined' in FF 16; result="+hhh.align);

Anyways, this was fixed by bug 767961 (this particular case was reported in bug 783396). Is it a matter of backporting the patch?
Nope.  That bug is fixed in 17, so unless we plan to backport to a 16 chemspill we're all set.  Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 783396

Updated

5 years ago
tracking-firefox17: ? → -
tracking-firefox18: ? → -
tracking-firefox19: ? → -
You need to log in before you can comment on or make changes to this bug.