Last Comment Bug 812212 - SeaMonkey trunk fails to compile (nsIPop3Service.idl)
: SeaMonkey trunk fails to compile (nsIPop3Service.idl)
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Mac OS X
: -- blocker (vote)
: Thunderbird 19.0
Assigned To: Mark Banner (:standard8, limited time in Dec)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-15 09:41 PST by Frank Wein [:mcsmurf]
Modified: 2012-11-19 13:28 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Possible fix (1.79 KB, patch)
2012-11-16 06:56 PST, Mark Banner (:standard8, limited time in Dec)
bugzilla: review+
Details | Diff | Splinter Review

Description Frank Wein [:mcsmurf] 2012-11-15 09:41:34 PST
The current SeaMonkey trunk build fails to compile on OSX, 64 bit build (clobber build on buildbox):
/builds/slave/comm-cen-trunk-osx64/build/objdir/i386/_virtualenv/bin/python -u /builds/slave/comm-cen-trunk-osx64/build/mozilla/config/pythonpath.py \
	  -I/builds/slave/comm-cen-trunk-osx64/build/mozilla/other-licenses/ply \
	  /builds/slave/comm-cen-trunk-osx64/build/objdir/i386/mozilla/dist/sdk/bin/header.py -I/builds/slave/comm-cen-trunk-osx64/build/mailnews/local/public -I../../../mozilla/dist/idl -I/builds/slave/comm-cen-trunk-osx64/build/mailnews/base/public  /builds/slave/comm-cen-trunk-osx64/build/mailnews/local/public/nsIPop3IncomingServer.idl -d .deps/nsIPop3IncomingServer.h.pp -o _xpidlgen/nsIPop3IncomingServer.h
nsIPop3Service.idl

Traceback (most recent call last):
  File "/builds/slave/comm-cen-trunk-osx64/build/mozilla/config/pythonpath.py", line 56, in <module>
    main(sys.argv[1:])
  File "/builds/slave/comm-cen-trunk-osx64/build/mozilla/config/pythonpath.py", line 48, in main
    execfile(script, frozenglobals)
  File "/builds/slave/comm-cen-trunk-osx64/build/objdir/i386/mozilla/dist/sdk/bin/header.py", line 524, in <module>
    idl.resolve(options.incdirs, p)
  File "/builds/slave/comm-cen-trunk-osx64/build/objdir/i386/mozilla/dist/sdk/bin/xpidl.py", line 287, in resolve
    p.resolve(self)
  File "/builds/slave/comm-cen-trunk-osx64/build/objdir/i386/mozilla/dist/sdk/bin/xpidl.py", line 251, in resolve
    self.IDL.resolve(parent.incdirs, parent.parser)
  File "/builds/slave/comm-cen-trunk-osx64/build/objdir/i386/mozilla/dist/sdk/bin/xpidl.py", line 287, in resolve
    p.resolve(self)
  File "/builds/slave/comm-cen-trunk-osx64/build/objdir/i386/mozilla/dist/sdk/bin/xpidl.py", line 253, in resolve
    parent.setName(type)
  File "/builds/slave/comm-cen-trunk-osx64/build/objdir/i386/mozilla/dist/sdk/bin/xpidl.py", line 265, in setName
    self.namemap.set(object)
  File "/builds/slave/comm-cen-trunk-osx64/build/objdir/i386/mozilla/dist/sdk/bin/xpidl.py", line 211, in set
    raise IDLError("name '%s' specified twice. Previous location: %s" % (object.name, self._d[object.name].location), object.location)
xpidl.IDLError: error: name 'nsIMsgCompFields' specified twice. Previous location: /builds/slave/comm-cen-trunk-osx64/build/mailnews/compose/public/nsIMsgCompFields.idl line 11:0
interface nsIMsgCompFields : nsISupports {
^, ../../../mozilla/dist/idl/nsIMsgCompFields.idl line 11:0
interface nsIMsgCompFields : nsISupports {
^
NEXT ERROR make[8]: *** [_xpidlgen/nsIImportService.h] Error 1
make[8]: *** Deleting file `_xpidlgen/nsIImportService.h'
make[7]: *** [public_export] Error 2
make[6]: *** [import_export] Error 2
Comment 1 Frank Wein [:mcsmurf] 2012-11-15 09:49:23 PST
Actually the problem is in nsIImportService.idl I think (parallel build, so not sure how much the build log gets messed up)
Comment 2 Mark Banner (:standard8, limited time in Dec) 2012-11-16 06:56:13 PST
Created attachment 682457 [details] [diff] [review]
Possible fix

Ok, I found two failures in looking at the logs. This is fallout from changing the mailnews build structures.

This should fix both the failures - basically rearranging the includes and replacing some by interface pre-definitions so that we're reducing the complexity of the idl includes system.
Comment 3 Mark Banner (:standard8, limited time in Dec) 2012-11-16 06:56:36 PST
p.s. feel free to land this on my behalf if I'm not about.
Comment 4 Frank Wein [:mcsmurf] 2012-11-19 13:24:08 PST
Comment on attachment 682457 [details] [diff] [review]
Possible fix

Looks good.
Comment 5 Frank Wein [:mcsmurf] 2012-11-19 13:28:23 PST
Pushed: https://hg.mozilla.org/comm-central/rev/ca6c314f4fef

Note You need to log in before you can comment on or make changes to this bug.