When enabling wifi from quick settings, we request all settings 6 times

RESOLVED DUPLICATE of bug 840322

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 840322
5 years ago
5 years ago

People

(Reporter: gwagner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
When I enable wifi from the quick-settings menue, we open the settings app.
I enabled logging for the settings API and I see that we request all settings 6 times.

I/Gecko   (  109): -*- SettingsManager: observe callback called! wifi.enabled 5
I/Gecko   (  109): -*- SettingsManager: Settings::receiveMessage: Settings:Change:Return:OK
I/Gecko   (  109): -*- SettingsManager: Settings:Change:Return:OK
I/Gecko   (  109): -*- SettingsManager: data:wifi.enabled:true
I/Gecko   (  109): 
I/Gecko   (  757): -*- SettingsManager: get lock!
I/Gecko   (  757): -*- SettingsManager: get: *
I/Gecko   (  757): -*- SettingsManager: info: get
I/Gecko   (  757): -*- SettingsManager: get lock!
I/Gecko   (  757): -*- SettingsManager: get: *
I/Gecko   (  757): -*- SettingsManager: info: get
I/Gecko   (  757): -*- SettingsManager: get lock!
I/Gecko   (  757): -*- SettingsManager: get: *
I/Gecko   (  757): -*- SettingsManager: info: get
I/Gecko   (  757): -*- SettingsManager: get lock!
I/Gecko   (  757): -*- SettingsManager: get: *
I/Gecko   (  757): -*- SettingsManager: info: get
I/Gecko   (  757): -*- SettingsManager: get lock!
I/Gecko   (  757): -*- SettingsManager: get: *
I/Gecko   (  757): -*- SettingsManager: info: get
I/Gecko   (  757): -*- SettingsManager: get lock!
I/Gecko   (  757): -*- SettingsManager: get: *
I/Gecko   (  757): -*- SettingsManager: info: get
I/Gecko   (  757): -*- SettingsManager: Request for '*' successful. Record count: 103....


When I just open the settings app, we request all settings one time.
These queries are generated by lazy loading of settings app. There are 6 sections related to wifi.

E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:61 in settings_init: ****init****
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:130 in settings_presetPanel: ****presetPanel**** 
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:78 in settings_loadPanel: ****loadPanel**** wifi-status
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:130 in settings_presetPanel: ****presetPanel**** 
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:78 in settings_loadPanel: ****loadPanel**** wifi-auth
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:130 in settings_presetPanel: ****presetPanel**** 
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:78 in settings_loadPanel: ****loadPanel**** wifi-joinHidden
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:130 in settings_presetPanel: ****presetPanel**** 
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:78 in settings_loadPanel: ****loadPanel**** wifi-wps
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:130 in settings_presetPanel: ****presetPanel**** 
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:78 in settings_loadPanel: ****loadPanel**** wifi-manageNetworks
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:130 in settings_presetPanel: ****presetPanel**** 
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:78 in settings_loadPanel: ****loadPanel**** wifi
E/GeckoConsole(11646): Content JS LOG at app://settings.gaiamobile.org/js/settings.js:130 in settings_presetPanel: ****presetPanel****
The UX for the wifi quick-setting has changed so this bug as originally filed is now invalid, but the problem of requesting the entire DB on each panel change is fixed by bug 840322.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 840322
You need to log in before you can comment on or make changes to this bug.