Closed Bug 81240 Opened 23 years ago Closed 23 years ago

Java plugin installation incomplete

Categories

(SeaMonkey :: Installer, defect)

x86
Windows 2000
defect
Not set
major

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: girish.manwani, Assigned: girish.manwani)

References

()

Details

Attachments

(1 file)

It seems after i get the plug-in downloader window and i downloaded and
installed the Java 2 Runtime Environment when i restarted the browser and did
about plugins i cannot see it.

Evidently visiting any page with Java asks you to download the plug-in again :(
removing samir from cc: list.
-------------------------------------------------------------------------------
ftp://ftp.netscape.com/pub/netscape6/english/6.0/windows/win32/smartupdate/jre.x
pi  --  05/16/2001 10:53:57
-------------------------------------------------------------------------------
      Sun Java 2
      ----------
      ** initInstall() returned: 0
      ** execute() returned: 0
      [1/1]	Executing: C:\DOCUME~1\ADMINI~1\LOCALS~1\TEMP\xpinstall.exe
      Install completed successfully
      ** performInstall() returned: 0
      Finished Installation  05/16/2001 10:53:59
--------------------------------------------------------------------------------

it should have been executing "jre13i.exe" not xpinstall.exe.  I'll attach the 
install.js file for jre.xpi.

Don, Dan, does any of this look familiar to you?  Was there a recent checkin to 
the execute() code?
the build id is 2001051604 .. windows nightly build
"xpinstall.exe" is the temporary file name of whatever is executed. I have no 
idea why we don't use the real name.
Found the problem.  Girish simply used the .zip file to install mozilla instead 
of running the windows installer.  By simply unzipping mozilla, 3rd party apps 
will not be able to locate where mozilla was unzipped to (there's no way to 
unless the entire hard drive is searched).

The windows mozilla installer creates registry keys in the windows registry so 
3rd party apps can locate it.

Closing this bug as invalid.
Status: UNCONFIRMED → RESOLVED
Closed: 23 years ago
Resolution: --- → INVALID
vfy
Status: RESOLVED → VERIFIED
*** Bug 223238 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Component: Installer: XPI Packages → Installer
QA Contact: agracebush → general
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: