Valgrind on tbpl detects leak - 136 bytes are definitely lost (direct) with js::ArgumentsObject* js::ArgumentsObject::create on the stack

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
major
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks: 1 bug, {memory-leak, regression, valgrind})

Trunk
x86_64
Linux
memory-leak, regression, valgrind
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 682339 [details]
m-c changeset a761bfc192b5 Valgrind stack with line numbers

Valgrind detects a leak of 136 bytes (direct) with js::ArgumentsObject* js::ArgumentsObject::create on the stack, see attached snippet which comes from:

https://tbpl.mozilla.org/php/getParsedLog.php?id=17064538&tree=Firefox&full=1

m-c changeset rev is a761bfc192b5.

It didn't happen in the previous Valgrind run here: https://tbpl.mozilla.org/?noignore=1&jobname=valgrind&rev=dd68409d7810

So I'm guessing the regression range is:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dd68409d7810&tochange=a761bfc192b5
Bug 809021 maybe? I can't tell if the arguments it talking about are the same as the arguments object...
(Reporter)

Comment 2

5 years ago
Created attachment 702970 [details]
Valgrind stack

A variant appeared in m-c d8be4bc4fba8 through https://tbpl.mozilla.org/php/getParsedLog.php?id=18854034&tree=Firefox&full=1

Checked in a suppression:

http://hg.mozilla.org/mozilla-central/rev/ce9cdd801a73
gkw: Might this be related to Bug 829421 ?

Apparently they had the same error reported on the gnome-shell.  Strangely, this might be a valgrind error, because this would only happen in case of OOM.
Flags: needinfo?(gary)
(Reporter)

Comment 4

5 years ago
Thanks, Nicolas! I've removed the suppression for this in https://hg.mozilla.org/mozilla-central/rev/425835f6a9e2

Assuming fixed by bug 829421.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(gary)
Resolution: --- → FIXED
(Reporter)

Comment 5

5 years ago
Reopening. I still see this on 64-bit builds after removing the suppression, see bug 829421 comment 15 and 16.

Suppression re-added by backing out suppression removal changeset: https://hg.mozilla.org/mozilla-central/rev/19f630648c80
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This is no longer occurring in Valgrind-on-TBPL runs.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.