If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Window manager] Home screen is always set to visible

RESOLVED FIXED

Status

Firefox OS
Gaia::System
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: timdream, Unassigned)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Looks like we got a typo in Bug #806425!

I have spotted the typo at |toggleHomescreen|, but I would like to test trusted UI before submit it.
Created attachment 682373 [details]
Github: https://github.com/mozilla-b2g/gaia/pull/6452

I am carrying over the blocking+ from the cloned bug; I don't think this should be a non-blocking bug anyway :-/

Let's get this quickly through review. ferjmoreno can you confirm the change? I have tested the payment UI through UI tests and verify the visibility change in home screen with console.log() in landing.js
Attachment #682373 - Flags: review?(ferjmoreno)
Comment on attachment 682373 [details]
Github: https://github.com/mozilla-b2g/gaia/pull/6452

vingtetun, if you are awake...
Attachment #682373 - Flags: review?(21)

Comment 3

5 years ago
Comment on attachment 682373 [details]
Github: https://github.com/mozilla-b2g/gaia/pull/6452

We've talked over IRC and we figured that an additional fix is required to avoid hiding the homescreen after reopening an app hosting a trusted UI. I'll be sending a PR with this fix right away.
Attachment #682373 - Attachment is obsolete: true
Attachment #682373 - Flags: review?(ferjmoreno)
Attachment #682373 - Flags: review?(21)

Comment 4

5 years ago
Created attachment 682413 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6459

Pointer to Github pull-request

Updated

5 years ago
Attachment #682413 - Flags: review?(timdream+bugs)
Attachment #682413 - Flags: review?(21)
Comment on attachment 682413 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6459

r=me. I don't like the fact that this fix brings dependency of window manager to trusted UI, but this seems to be the minimal fix.
Attachment #682413 - Flags: review?(timdream+bugs)
Attachment #682413 - Flags: review?(21)
Attachment #682413 - Flags: review+
https://github.com/mozilla-b2g/gaia/pull/6459
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #2)
> Comment on attachment 682373 [details]
> Github: https://github.com/mozilla-b2g/gaia/pull/6452
> 
> vingtetun, if you are awake...

No way. My sleep schedule is completely f*** up :(
You need to log in before you can comment on or make changes to this bug.