The default bug view has changed. See this FAQ.

[AccessFu] Jelly Bean 4.2: TalkBack announces that a page finished loading only after one touches the display

VERIFIED FIXED in Firefox 18

Status

()

Core
Disability Access APIs
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: MarcoZ, Assigned: eeejay)

Tracking

({relnote})

Trunk
mozilla20
ARM
Android
relnote
Points:
---

Firefox Tracking Flags

(firefox17- wontfix, firefox18+ verified, firefox19+ verified, firefox-esr17- wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
STR:
1. On a device running Jelly Bean 4.2 with TalkBack on, load any page from your home page.

Expected: When the page finishes loading, TalkBack should announce the fact that the page was loaded.
Actual: Some high-pitched beeps are heard indicating that a page scroll occurred, and "Back button disabled" is announced, but no page load.

2. Touch the display.

Result: Now, TalkBack announces the page load completion.

My impression is that the browser window loses focus to the Back button, and that the page load therefore is not being spoken until focus is returned to the window.

This is behavior introduced with Android Jelly Bean 4.2.

Updated

4 years ago
status-firefox17: affected → wontfix
status-firefox-esr17: affected → wontfix
tracking-firefox17: ? → -
tracking-firefox18: ? → +
tracking-firefox19: ? → +
tracking-firefox-esr17: ? → -
Keywords: relnote

Comment 1

4 years ago
dbolter - please reassign as necessary.
Assignee: nobody → dbolter
(Assignee)

Updated

4 years ago
Assignee: dbolter → eitan
(Assignee)

Comment 2

4 years ago
Created attachment 682622 [details] [diff] [review]
Fix accessibility announcements.

I can't explain what changed on the Android end to make this happen. But the solution here mimics View.announceForAccessibility(), so I feel pretty good about it.
Attachment #682622 - Flags: review?(blassey.bugs)
Attachment #682622 - Flags: review?(blassey.bugs) → review+
(Reporter)

Comment 3

4 years ago
I can confirm this fixes the problem and also still works on older Android versions as expected. Tested with a local build.
(Reporter)

Comment 4

4 years ago
I pushed this on Eitan's behalf so it still makes the ride, hopefully, to Aurora in time:
https://hg.mozilla.org/integration/mozilla-inbound/rev/66473f7c498f
Target Milestone: --- → mozilla19
https://hg.mozilla.org/mozilla-central/rev/66473f7c498f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: mozilla19 → mozilla20
(Reporter)

Comment 6

4 years ago
Verified fixed in Nightly/20.0a1 of November 20, 2012.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

4 years ago
Comment on attachment 682622 [details] [diff] [review]
Fix accessibility announcements.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Android 4.2
User impact if declined: Blind users won't hear automatic announcements when new tabs are opened, pages finish loading, etc., once they update to Android 4.2
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #682622 - Flags: approval-mozilla-beta?
Attachment #682622 - Flags: approval-mozilla-aurora?

Comment 8

4 years ago
Comment on attachment 682622 [details] [diff] [review]
Fix accessibility announcements.

[Triage comment]
Low risk a11y fix, approving for Aurora/Beta.
Attachment #682622 - Flags: approval-mozilla-beta?
Attachment #682622 - Flags: approval-mozilla-beta+
Attachment #682622 - Flags: approval-mozilla-aurora?
Attachment #682622 - Flags: approval-mozilla-aurora+
(Reporter)

Comment 9

4 years ago
Pushed:
https://hg.mozilla.org/releases/mozilla-aurora/rev/25369927b364
https://hg.mozilla.org/releases/mozilla-beta/rev/65e445cc6655
status-firefox18: affected → fixed
status-firefox19: affected → fixed
(Reporter)

Comment 10

4 years ago
Additional verifications on Aurora built on Nov 27, 2012, and Beta, released November 27, 2012.
status-firefox18: fixed → verified
status-firefox19: fixed → verified
You need to log in before you can comment on or make changes to this bug.