Last Comment Bug 812484 - [Desktop Build] Nightly 64-bit Linux build broken
: [Desktop Build] Nightly 64-bit Linux build broken
Status: RESOLVED FIXED
:
Product: Firefox OS
Classification: Client Software
Component: GonkIntegration (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 815805
Blocks: 816961
  Show dependency treegraph
 
Reported: 2012-11-16 05:07 PST by Ben Francis [:benfrancis]
Modified: 2013-08-08 15:22 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ben Francis [:benfrancis] 2012-11-16 05:07:10 PST
I get the following when I try to launch the build downloaded from http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central/b2g-19.0a1.en-US.linux-x86_64.tar.bz2

XPCOMGlueLoad error for file /home/username/Downloads/b2g/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

This also effects the "Firefox OS Simulator" extension when used on 64-bit Linux.

I'm using Ubuntu.
Comment 1 Myk Melez [:myk] [@mykmelez] 2012-11-17 23:46:19 PST
I'm unable to reproduce on my Fedora 17 64-bit test VM.  But lots of people over in bug 723487 are having the same problem with Firefox and Thunderbird.
Comment 2 Myk Melez [:myk] [@mykmelez] 2012-11-26 16:18:02 PST
Today I set up a VMware VM and installed Ubuntu 12.10 64-bit into it.  Then I downloaded, unpacked, and ran the latest Central nightly build from the URL in comment 0.  But I still couldn't reproduce.

Nor can I reproduce with the latest version of Firefox OS Simulator (which bundles Aurora builds).

Perhaps there is something about running Linux in a VM that is different from running it on a real machine?  Or maybe it's an issue with older versions of the OS?  Two others reporting this problem over in r2d2b2g issue #105 <https://github.com/mozilla/r2d2b2g/issues/105> have Ubuntus 10.04 and 10.10.
Comment 3 Ben Francis [:benfrancis] 2012-11-27 02:04:49 PST
I'm using Ubuntu 11.10, has anyone tried with Ubuntu 12.04 LTS?
Comment 4 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2013-07-30 18:09:59 PDT
(In reply to Myk Melez [:myk] [@mykmelez] from comment #1)
> I'm unable to reproduce on my Fedora 17 64-bit test VM.  But lots of people
> over in bug 723487 are having the same problem with Firefox and Thunderbird.

No activity here since Nov2012, and bug 723487 has been fixed (since ~may2013). Anything left to do here, or can we call this FIXED?

Note You need to log in before you can comment on or make changes to this bug.