Closed Bug 812583 Opened 9 years ago Closed 9 years ago

mach needs a way to run (some) mochitests without --autorun or --close-when-done

Categories

(Firefox Build System :: Mach Core, enhancement)

x86_64
Linux
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 818819

People

(Reporter: zwol, Unassigned)

References

(Blocks 1 open bug)

Details

It appears that when asked to run mochitests, mach unconditionally passes --autorun --close-when-done to runtests.py.  This is no good for test development: I typically want to load up a single test file in the browser and hit reload on it a whole bunch of times while editing.  It is also no good for manually confirming that a particular test still passes 100%, because you don't get an error summary in the browser or on the command line, and the individual subtests go by much too fast and buried in debugging chatter.  And it is *also* no good for manually confirming that your test is still in the right giant list in the relevant Makefile, because the test runner doesn't bother displaying the list of tests-to-run in --close-when-done mode.

Please add some sort of switch that makes 'mach --something mochitest-whatever TEST/PATH' behave exactly as 'cd $build/_tests/testing/mochitest && python runtests.py TEST/PATH' would.
That's interesting because mach currently runs mochitests through the make targets. We intend to refactor mach to call into the mochitest Python runner directly.
Duplicate of this bug: 818762
Depends on: 818819
I implemented this as part of bug 818819.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818819
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.