Remote debugging doesn't work with jsloader.reuseGlobal == true

RESOLVED DUPLICATE of bug 811784

Status

RESOLVED DUPLICATE of bug 811784
6 years ago
6 years ago

People

(Reporter: fabrice, Unassigned)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
In https://mxr.mozilla.org/mozilla-central/source/toolkit/devtools/debugger/server/dbg-server.jsm the exported object is built by a sandboxed object that loads a script. Somehow this fails!
I think bug 811784 may have fixed this.  Can you try a build with that patch?
(Reporter)

Comment 2

6 years ago
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #1)
> I think bug 811784 may have fixed this.  Can you try a build with that patch?

No luck with that either.
I tried running m-i (cset b401cbf179c1) with the pref set to true and it still works for me. I looked at the pushlog and saw that bug 811784 had been backed out, so perhaps that's what broke it, although comment 2 seems to imply that you tried without that as well.

I'll try another build on Monday with bug 811784 applied again.
Indeed, backing out the backout (cset d770dc9a50e8) breaks a lot of things:

JavaScript error: resource:///modules/devtools/DebuggerUI.jsm, line 263: TypeError: DebuggerServer is undefined

Error: ERROR addons.xpi: Error during startup file checks, rolling back any database changes: TypeError: XPIDatabase is undefined
Source File: resource://gre/modules/XPIProvider.jsm
Line: 3031
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
So I'm confused, is this broken right now, or does bug 811784 cause this bug?
Flags: needinfo?(fabrice)
In my testing m-i tip works, but bug 811784 breaks it.
Ok, that makes sense.  Let's just deal with this in Bug 811784
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 811784
(Reporter)

Updated

6 years ago
Flags: needinfo?(fabrice)

Updated

6 years ago
blocking-basecamp: ? → +
You need to log in before you can comment on or make changes to this bug.