[FM Radio] [Music] music plays when both apps are loaded

VERIFIED FIXED in B2G C2 (20nov-10dec)

Status

Firefox OS
Gaia::Music
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: tchung, Assigned: dkuo)

Tracking

unspecified
B2G C2 (20nov-10dec)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: DUPEME, [LOE:S])

(Reporter)

Description

5 years ago
When both FM Radio and Music App is playing, both have audio playing. 

We need a way to trigger if one or the other is running, preferably the last app to be triggered.   For example, if i had FM radio on , and i exit, then i launch Music and play a song, we should stop the radio transmission and start playing my music selection.  and vice versa.

Repro:
1) install 11-16 daily unagi build
gaia: 620399e19efe849b9dddeffe7e11003847f6b268
gecko: f423bd0551fcf872eb58064ed72ed2a4aed2c2d2
2) plug headset in, and turn on all your audio apps (fmradio, music)
3) verify audio plays between both radio and music app over each other.  there's no logic to detect if one is running or not.

Expected:
- close audio on one app, when opening the other

Actual:
- audio plays in both apps
QA Contact: mozillamarcia.knous
This likely occurs with video as well, but my phone freezes when I have all three apps running, so I cannot confirm.
This related to the bug:805333
Depends on: 805333
Whiteboard: DUPEME
Component: Gaia → Gaia::Music

Updated

5 years ago
Duplicate of this bug: 810969
Blocks: 802677
blocking-basecamp: ? → +
Priority: -- → P1
Target Milestone: --- → B2G C2 (20nov-10dec)
Assignee: nobody → dkuo

Comment 4

5 years ago
This depends on bug 805333. Before bug 805333 is resolved, we can't proceed this case further.
Whiteboard: DUPEME → DUPEME, [LOE:S]

Comment 5

5 years ago
After bug 805333 is resolved, we might need 2 days additional efforts on this.
Hi Dominic, now that 805333 landed, can you keep everyone updated as to where you are with the bug? thanks
Once bug 815452 lands, this should be fixed.
Depends on: 815452
(Assignee)

Comment 8

5 years ago
There is one follow up work for Music app, please see bug 819873, thanks.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 9

5 years ago
(In reply to Dominic Kuo [:dkuo] from comment #8)
> There is one follow up work for Music app, please see bug 819873, thanks.

Is there still Music work to be done here?  I can still reproduce playing of music and FM radio together.
That followup work doesn't affect simultaneous playback.  Are you sure your build includes bug 815452?

Comment 11

5 years ago
I guess not.  I just tried again and it's working now.  Thanks.
Verified fixed using the latest night build (201212112). I verified by running both apps and only one app plays at a time.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.