Over 6GiB heap-unclassified in less than 48 hours

RESOLVED DUPLICATE of bug 811228

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 811228
6 years ago
6 years ago

People

(Reporter: Stephan Sokolow, Unassigned)

Tracking

18 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

(Reporter)

Description

6 years ago
Since its last update, my Aurora-channel Firefox has been leaking like crazy (version 18.0a2 (2012-11-14)). The first time I noticed this was when, one morning, I awoke to find Firefox consuming almost all 16GiB of my RAM and my desktop dog-slow because it was running out of the swap.

At present, its resident size is 8011MiB (after less than 48 hours and possibly less than 24) and about:memory is showing this breakdown:

7,755.59 MB (100.0%) -- explicit
├──6,463.03 MB (83.33%) ── heap-unclassified
├────710.12 MB (09.16%) -- js-non-window
│    ├──551.63 MB (07.11%) -- compartments
│    │  ├──528.64 MB (06.82%) -- non-window-global
│    │  │  ├──321.14 MB (04.14%) ++ (730 tiny)
│    │  │  └──207.50 MB (02.68%) -- compartment([System Principal], chrome://browser/content/browser.xul)
│    │  │     ├──154.31 MB (01.99%) ++ gc-heap
│    │  │     └───53.19 MB (00.69%) ++ (5 tiny)
│    │  └───23.00 MB (00.30%) ++ no-global
│    ├──138.89 MB (01.79%) -- gc-heap
│    │  ├──101.37 MB (01.31%) ── decommitted-arenas
│    │  └───37.52 MB (00.48%) ++ (3 tiny)
│    └───19.59 MB (00.25%) ++ runtime
├────455.74 MB (05.88%) ++ window-objects
└────126.70 MB (01.63%) ++ (17 tiny)
Whiteboard: [MemShrink]
This is probably a dup of bug 770612 and bug 811228.  Can you try the steps suggested in bug 811228 comment 10 and let us know if that fixes the problem?
Flags: needinfo?(from_bugzilla2)
This is probably a dup of bug 770612 and bug 811228.  Can you try the steps suggested in bug 811228 comment 10 and let us know if that fixes the problem?
Ok, it sounds like this is not the same as bug 770612, but is the same as 811228.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 770612
I think you duped this to the wrong bug?
Yes, sorry.
Duplicate of bug: 811228
(Reporter)

Comment 6

6 years ago
Huh. Marking a bug as a duplicate doesn't clear "needinfo" requests. Is that by design?

Also, do you still want me to try that test? It's been a bit hard to observe the space consumption climbing lately (it's fine before I go to bed and dead with a ton of apps pushed to swap when I wake up) but I could still give it a shot.
Flags: needinfo?(from_bugzilla2)
Probably no point trying the test, because your symptoms don't match the THP symptoms.
You need to log in before you can comment on or make changes to this bug.