If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[b2g-bluetooth] unable to send files from unagi device to Recipient

VERIFIED FIXED

Status

Firefox OS
Gaia::Bluetooth
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: tchung, Assigned: ericchou)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: smoketest, dogfood)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 682706 [details]
screenshot

When attempting to bluetooth transfer a file from one unagi to another device (or laptop), it will fail even before sending.

* NOte: i was able to transfer inbound from a laptop to the phone, but not outbound.

* See screenshot

Logcat: 
11-16 19:41:23.761: E/GeckoConsole(12731): [JavaScript Warning: "XUL box for p element contained an inline #text child, forcing all its children to be wrapped in a block." {file: "app://bluetooth.gaiamobile.org/transfer.html" line: 0}]
11-16 19:41:23.921: E/GeckoConsole(10274): [JavaScript Warning: "XUL box for p element contained an inline #text child, forcing all its children to be wrapped in a block." {file: "app://bluetooth.gaiamobile.org/transfer.html" line: 0}]

Repro:
1) install 11-14 stable unagi build
** buildID = 20121115145434
** gecko: 76848b5c67e6c164b28f366534e5eeab8fcadc2a
** gaia: 1c884f41292650615b04ca9f40cab981ea9e4d00
2) Pair bluetooth settings with another Unagi device or laptop w/bluetooth support
3) once successfully paired, launch Gallery, and tap an image
4) Click the Share option in an image , select "Bluetooth Transfer"
5) select the device you want to bluetooth transfer to, and click ok
6) Verify BT file transfer fails immediately.

Expected:
- BT file transfer outbound an image to another device or computer

Actual:
- BT file transfer fails to outbound send
(Reporter)

Updated

5 years ago
Blocks: 727618
Component: Gaia::System → DOM: Device Interfaces
Product: Boot2Gecko → Core
(Reporter)

Comment 1

5 years ago
i think this is a core bug, but move back to Gaia if it's not.
(Assignee)

Comment 2

5 years ago
This may be caused by the wrong "Name" header, and it has been filed as Bug 812412. Please check if this issue still exists after bug 812412 is fixed.
Depends on: 812412
blocking-basecamp: ? → +
Assignee: nobody → echou
I can't send a file from my Unagi phone with a 2012-11-14 build.
(Assignee)

Comment 4

5 years ago
Hi Andrew,

  We still have problem on sending file now. The related bug is Bug 814323.

Eric
Depends on: 814323
(Assignee)

Comment 5

5 years ago
(In reply to Andrew Overholt [:overholt] from comment #3)
> I can't send a file from my Unagi phone with a 2012-11-14 build.

Sorry, I forgot to ask for more details. Andrew, did you get the same error as the attached screenshot? I guess you may hit Bug 814323.
(Assignee)

Comment 6

5 years ago
Bug 816429 is another file-sharing related bug.
Depends on: 816429
Setting priority based on triage discussions.  Feel free to decrease priority if you disagree.
Priority: -- → P1
(Assignee)

Comment 8

5 years ago
+Needinfo QA Walter

Hi Walter,

All dependent bugs are resolved. Could you please check if the bug has been fixed? Thank you.

Eric
Flags: needinfo?(wachen)
(Assignee)

Comment 9

5 years ago
This has been fixed by Ian's Pull Request of Bug 814323.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Hi, this is fixed as far as I saw on:
https://releases.mozilla.com/b2g/
2012-12-02 build
Status: RESOLVED → VERIFIED
Flags: needinfo?(wachen)
Component: DOM: Device Interfaces → Gaia
Product: Core → Boot2Gecko
Component: Gaia → Gaia::Bluetooth File Transfer
QA Contact: wachen
You need to log in before you can comment on or make changes to this bug.